Firefox opens a blank webpage for Windows Media Player sound files (e.g. "Listen" on Amazon)

RESOLVED DUPLICATE of bug 284963

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 284963
14 years ago
13 years ago

People

(Reporter: yathribjr, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

This problem occurs when opening Windows Media Player sound clips, particularly
those of CD retailer websites. Before the current version (1.0.1) of Firefox,
clicking on a music clip in Windows Media format launched the Windows Media
player while keeping the browser page still.

The problem now is that when opening a Windows Media music clip, the browser
opens a blank page with a "hurl.exe" URL before launching the Windows Media
Player application, effectively treating the music clip as a blank new page.
This is quite annoying because you have to keep pressing "BACK" to play more
soundclips instead of remaining on the correct webpage. Basically, clicking on a
Windows Media Player clip should not result in leaving the webpage and launching
a blank webpage. In versions 0.8 and 1.0, this problem did not occur.


Reproducible: Always

Steps to Reproduce:
1.Visit a site with Windows Media Player clips such as Amazon.com
2. Click on a Windows Media Player clip for a music album
3. Watch as the browser screen goes blank while launching the Windows Media
Player application instead of remaining still

Actual Results:  
A blank webpage opens with a URL such as this:

http://www.content.loudeye.com/scripts/hurl.exe?clipid=070497101060006900&cid=600111

(Of course, the exact clipid will differ.)

Expected Results:  
The webpage should have remained as is while launching the Windows Media Player
application

System details:

Pentium 4 3.0E
512MB DDR400
Asus P4P-800E Deluxe motherboard
Seagate 80MB SATA hard drive

Windows Media Player 10

Comment 1

14 years ago
I also have this problem with 1.0.1. The problem was not present in 1.0 or earlier.

The following error message appears in the JavaScript console when this error
occurs:

Security Error: Content at
http://www.content.loudeye.com/scripts/hurl.exe?clipid=003544901010006900&cid=600111
may not load or link to file:///C:%5CDOCUME~1%5CJonah%5CLOCALS~1%5CTemp%5C2iz2C.htm.

Apparently, the Amazon application "hurl.exe" is trying to directly access a
page in the user's cache (I'm guessing to alleviate unnecessary traffic on
Amazon's servers).
Summary: Firefox opens a blank webpage for Windows Media Player sound files → Firefox opens a blank webpage for Windows Media Player sound files
(Reporter)

Comment 2

14 years ago
Jonah Bishop is right about the JS warning. 

Meanwhile, I can now safely say that virtually all sites that use Windows Media
Player sound clips have the same problem. 

FF 1.0.2 doesn't seem to address this yet. 

I still think that it needs to be remedied for virtually all Windows users have
this helper application, and will come across sound clips in this format sooner
or later. (In reply to comment #1)
> I also have this problem with 1.0.1. The problem was not present in 1.0 or
earlier.
> 
> The following error message appears in the JavaScript console when this error
> occurs:
> 
> Security Error: Content at
>
http://www.content.loudeye.com/scripts/hurl.exe?clipid=003544901010006900&cid=600111
> may not load or link to
file:///C:%5CDOCUME~1%5CJonah%5CLOCALS~1%5CTemp%5C2iz2C.htm.
> 
> Apparently, the Amazon application "hurl.exe" is trying to directly access a
> page in the user's cache (I'm guessing to alleviate unnecessary traffic on
> Amazon's servers).

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1
> 
> This problem occurs when opening Windows Media Player sound clips, particularly
> those of CD retailer websites. Before the current version (1.0.1) of Firefox,
> clicking on a music clip in Windows Media format launched the Windows Media
> player while keeping the browser page still.
> 
> The problem now is that when opening a Windows Media music clip, the browser
> opens a blank page with a "hurl.exe" URL before launching the Windows Media
> Player application, effectively treating the music clip as a blank new page.
> This is quite annoying because you have to keep pressing "BACK" to play more
> soundclips instead of remaining on the correct webpage. Basically, clicking on a
> Windows Media Player clip should not result in leaving the webpage and launching
> a blank webpage. In versions 0.8 and 1.0, this problem did not occur.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Visit a site with Windows Media Player clips such as Amazon.com
> 2. Click on a Windows Media Player clip for a music album
> 3. Watch as the browser screen goes blank while launching the Windows Media
> Player application instead of remaining still
> 
> Actual Results:  
> A blank webpage opens with a URL such as this:
> 
>
http://www.content.loudeye.com/scripts/hurl.exe?clipid=070497101060006900&cid=600111
> 
> (Of course, the exact clipid will differ.)
> 
> Expected Results:  
> The webpage should have remained as is while launching the Windows Media Player
> application
> 
> System details:
> 
> Pentium 4 3.0E
> 512MB DDR400
> Asus P4P-800E Deluxe motherboard
> Seagate 80MB SATA hard drive
> 
> Windows Media Player 10

Comment 3

13 years ago
This problem still occurs in Firefox 1.0.4, and should be confirmed. It seems to
me that this should be fixed, since a number of users use Windows Media Player
to play online content. I'll nominate this for blocking status.
Flags: blocking-aviary1.1?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050622
Firefox/1.0+ ID:2005062207

Can you provide a link to a page containg a file with this error? (or steps to
navigate to one)

Clicking on the link
http://www.content.loudeye.com/scripts/hurl.exe?clipid=070497101060006900&cid=600111
opens a music file into WMP 10 and plays fine for me.

Also you should test with a trunk build before reporting bugs. Does this occur
with a trunk build from:
<http://www.mozilla.org/releases/nightly.html> 
(Reporter)

Comment 5

13 years ago
Windows Media Player (WMP) sound clips will play just fine with Firefox 1.0.1 to
1.0.4. If you read the initial description, the problem is that in addition to
launching WMP to play the sound clip, Firefox 1.0.1 to 1.0.4 also opens a blank
webpage once its link is clicked. In effect, Firefox treats this link as a new
(blank) page when it ought to just launch the helper application. What should
instead happen upon clicking a link is for WMP to launch and play the clip while
the browser doesn't move away from the page containing the sound clip link.

I'm currently using two computers--one has WMP9 and the other WMP10. Regardless
of which version, the problem persists. 

Thanks!
Then this is probably a dupe of bug 241972
(Reporter)

Comment 7

13 years ago
I believe that it's another bug:

(1) 241972 specifies that the problem occurs with Firefox 0.8. Jonah Bishop and
I encountered this problem with FF1.0.1 and up. 

(2) From what I understand of 241972, you need to disable popup blocking for the
problem to occur. I never disable popup blocking. 

(3) 241972 appears to deal with downloading issues in general. This problem is
confined just to WMP audio clips. For example, Real Player audio clips do not
cause the browser to open a blank webpage.

Thanks again!

Comment 8

13 years ago
Here is how I can reproduce this error in Firefox 1.0.4 (I have not tested this
in the trunk builds, but will do so later this evening):

1. Browse to this Jimi Hendrix album at Amazon.com (the URL may wrap around
since it's so long):
http://www.amazon.com/exec/obidos/tg/detail/-/B000002P5U/ref=m_art_li_3/102-2552034-2408161?v=glance&s=music

2. Click on any of the Windows Media Player "Listen" links under the "Listen to
Samples" heading.

3. Note that Windows Media Player starts up and plays the sample successfully,
but the browser window becomes blank. Also note that a JavaScript warning has
been placed in the JavaScript console.

Expected Behavior:
The browser window should have been redirected back to the page from which we
clicked the listen link (the URL I provided in this comment).

IIRC, in Firefox 1.0, clicking on one of the "Listen" links would start WMP and
return me to the product's page (as it should). One of the security changes
since then has broken this (IMO, correct) behavior.

Comment 9

13 years ago
I can confirm that this problem appears in the nightly builds. I tested with
Deer Park Alpha 1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050623 Firefox/1.0+), following the steps from my previous comment, and
got the following security error in the JavaScript console:

Security Error: Content at
http://www.content.loudeye.com/scripts/hurl.exe?clipid=002701601150006900&cid=600111
may not load or link to file:///C:/DOCUME~1/Jonah/LOCALS~1/Temp/pyb26.htm.
dupe of a b4 blocker on my list
Flags: blocking-aviary1.1?
Whiteboard: DUPEME
Dupe to bug 241972 as per comment 10

*** This bug has been marked as a duplicate of 241972 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 12

13 years ago
I'm still not convinced that this bug is a duplicate of 241972. The links at
Amazon.com are not using "target=", and a new window is not being opened. It's
the *current* window that is being manipulated.

I can have one FF window open, with only one tab, and see this issue. No
secondary windows are created. Perhaps I'm overlooking something, but I think
this is a separate issue.

Besides, I don't see any mention of the JavaScript security error in bug 241972.
Doesn't that alone indicate that something else is going on, or am I mistaken?
(In reply to comment #12)
> I'm still not convinced that this bug is a duplicate of 241972. The links at
> Amazon.com are not using "target=", and a new window is not being opened. It's
> the *current* window that is being manipulated.

Good point, please reopen (or comment as such) if the bug still exists after bug
241972 is fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

13 years ago
I still believe that it's another bug:

(1) 241972 specifies that the problem occurs with Firefox 0.8. I encountered
this problem with FF1.0.1 and up. 

(2) From what I understand of 241972, you need to disable popup blocking for the
problem to occur. I never disable popup blocking. 

(3) 241972 appears to deal with downloading issues in general. 285319 is
confined just to WMP audio clips. For example, Real Player audio clips do not
cause the browser to open a blank webpage in the current window, despite these
being hurl.exe clips as well.

This is a key point: If this problem isn't confined to WMP as 241972 suggests,
then why is it that Real Player clips do not provoke the same errors?

(4) 285319 does not concern opening another window upon clicking on a WMP audio
link as 241972 would suggest. As Jonah Bishop observed, it's that the current
window goes blank upon clicking on a WMP audio link. 

(5) Amazon isn't the only site afflicted by 285319. Also visit other sites such
as http://www.npr.org that use WMP audio clips and you'll see that the problem
remains. 285319 isn't confined to those who choose to forego popup blocking;
rather, it affects the vast majority of users who run FF "as is" with popup
blocking on and encounter WMP audio clips on a regular basis. 

On advice, I will wait for the pending resolution of 241972 before commenting
further, but it seems to me that 241972 is unrelated to 285319.

Thanks again!

Comment 15

13 years ago
Not a dup of bug 241972.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Firefox opens a blank webpage for Windows Media Player sound files → Firefox opens a blank webpage for Windows Media Player sound files (e.g. "Listen" on Amazon)

Comment 16

13 years ago
I'm re-requesting blocking status, as per comment #15.

Also, I am still seeing this issue in the branch nightly from 08-28-2005, and in
the official 1.0.6 build. The "Security Error" message still appears in the
JavaScript console.
Flags: blocking1.8b4?
Unfortunately, I think it's more likely to be wontfix, or technical evangelism
for Microsoft, than a blocker for Firefox.

It's hard to tell exactly what part of the operation is doing what, but roughly
what happens when you click one of the links is that you load a audio/x-ms-wax
file, which is an XML playlist file that the WMP plugin uses to find the URL
that it should tell the external player to load. Then, the plugin apparently
creates and tries to load a temporary local file which consists of just "<html>
<script language='javascript'>window.history.go(-2);</script> </html>" and since
that's an http page trying to load a file URL, CheckLoadURI says no.
Assignee: bugs → nobody
Component: File Handling → Plug-ins
Product: Firefox → Core
QA Contact: aebrahim-bmo-507 → plugins
Version: unspecified → Trunk

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-
Hmm... What URI are we "supposed" to be showing after all is said and done?
For npr.org, which is less trouble to test:

1. On http://www.npr.org/ click the "Hourly Newscast" link, which loads
2.
http://www.npr.org/dmg/dmg.php?getNewsCast=true&NPRMediaPref=WM&getUnderwriting=1
which is the audio/x-ms-wax file that triggers opening the external player, at
which point the plugin (I assume, not the player) creates and tries to load
3. file:///C:/DOCUME~1/USERN~1/LOCALS~1/Temp/vef2C.htm which wants to do
window.history.go(-2) to get back to #1, npr.org, where we started and are
supposed to end up.

Apparently, IE handles audio/x-ms-wax differently, dispatching to the external
handler without loading anything plugin-like, and the window.history.go(-2) is
just for our benefit, since loading that /dmg/dmg.php URL directly in IE doesn't
appear to load a local file or go back.
> 3. file:///C:/DOCUME~1/USERN~1/LOCALS~1/Temp/vef2C.htm which wants to do
> window.history.go(-2) to get back to #1, npr.org, where we started and are
> supposed to end up.

CheckLoadURI shouldn't block that...

Comment 21

13 years ago
Just another data point which may shed some light (or not). I don't have this
issue with WMP 6.4 & Win98 , an extra window does not open. 

Mozilla/5.0 (Windows; U; Win98; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 

Comment 22

13 years ago
*** Bug 307507 has been marked as a duplicate of this bug. ***
*** Bug 311127 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
This bug applies to all Windows Media MIME-types (video/x-ms-asf,
video/x-ms-wm, 	audio/x-ms-wma, audio/x-ms-wax, video/x-ms-wmv, video/x-ms-wvx) 	

In all cases, clicking on the media file link causes  
Firefox to go blank page and JavaScript Console shows
Security Error: Content at http://media_file_URL may not load or link to
file:///C:/DOCUME~1/User/LOCALS~1/Temp/ne4B8.htm.

Comment 25

13 years ago
Workaround:
Change ASX from Plugin to "Open with default application" in
Options -> Downloads -> View & Edit Actions.

*** This bug has been marked as a duplicate of 284963 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.