XML Parsing error on about and other dialogs: undefined entities

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: Mike C. Fletcher, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20050222 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20050222 Firefox/1.0

This is Firefox 1.0.1 built from source on a Gentoo AMD64 box using the ~amd64
ebuild and installed over Firefox 1.0, both using the mozsvg USE flag.  On
selecting Help|About, a Gecko dialog appears with the message (note, this is
copied manually, as copy/paste doesn't work for the gecko dialog):

XML Parsing Error: undefined entity
Location: chrome://browser/content/aboutDialog.xul
Line Number 19, Column 16:
          title="&aboutDialog.title;" creditsLabel="&copyright;"
aboutLabel="&aboutLink;"
_________________^

Similar errors show up for every dialog-based choice under the tools, help and
bookmarks menu.

Even just typing about: in the address bar gives this error:

XML Parsing Error: undefined entity Location:
jar:resource:///chrome/toolkit.jar!/content/global/about.xhtml Line Number 68,
Column 52:<img src="chrome://browser/content/about.png"
alt="&brandShortName;"/></a> ---------------------------------------------------^

I'm wondering if it may be a problem with the theme that was installed with
Firefox 1.0 (Plastikfox Crystal SVG) not being compatible with 1.0.1, but I was
under the impression that Firefox is supposed to disable those themes not known
to work with the current version when doing an upgrade.

Reproducible: Always

Steps to Reproduce:
1. emerge firefox 1.0.1 over firefox 1.0
2. open firefox
3. choose Help|About, or any other dialog-based dialog

Actual Results:  
Gecko dialog about undefined entities.

Expected Results:  
The selected dialog.

about:buildconfig

Build platform
target
x86_64-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-fPIC -pthread -pipe
c++ 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -fPIC -Wno-deprecated -fshort-wchar
-pthread -pipe

Configure arguments
--disable-ldap --disable-mailnews --enable-crypto --disable-composer
--enable-single-profile --disable-profilesharing --enable-optimize=-O1
--enable-old-abi-compat-wrappers --disable-installer --disable-pedantic
--enable-crypto --with-system-jpeg --with-system-png --with-system-zlib
--without-system-nspr --enable-default-toolkit=gtk2 --enable-ipv6
--disable-xinerama --disable-xprint --enable-freetype2 --enable-freetypetest
--disable-debug --disable-tests --enable-reorder --enable-strip
--enable-strip-libs --enable-xft --enable-oji --enable-mathml --disable-jsd
--disable-xpctools --disable-gnomevfs --enable-svg --enable-svg-renderer-cairo
--with-default-mozilla-five-home=/usr/lib/MozillaFirefox
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth,-venkman,-gnomevfs
--prefix=/usr --host=x86_64-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --loc

Comment 1

13 years ago
(In reply to comment #0)
> This is Firefox 1.0.1 built from source on a Gentoo AMD64 box using the ~amd64
> ebuild and installed over Firefox 1.0,

Says it all. Don't install over. Deinstall properly and install then. Perhaps
you need a new profile too. If this helps, please resolve as invalid.
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

13 years ago
Okay, uninstalling and re-installing alone did not help (emerge unmerge firefox,
emerge firefox).  Creating a new profile did eliminate the problem, but I'm not
sure about marking this "invalid", isn't this something that should be fixed?  I
mean you shouldn't have to manually recreate a profile (i.e. copy all the
important data over)... seems a bit involved for a point upgrade... shouldn't
firefox be noticing the out-of-date information in the profile and cleaning it up?

Still, that was what was requested, so I suppose I'll mark it as such.  Thanks
for the pointer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
Spoke too soon.  Starting firefox with firefox --ProfileManager and then
selecting the new profile (now the only profile) does load in such a way that
the bug is fixed, but just running firefox without --ProfileManager produces the
same symptoms.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

13 years ago
Perhaps this bug should be renamed to something like "XBL parsing errors when
upgrading to 1.0.1 with old profile" or something? Or, mark as invalid and file
a new bug report if you can find some foolproof steps to reproduce.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 6

12 years ago
*** Bug 310621 has been marked as a duplicate of this bug. ***
Assignee: bross2 → nobody
Since this worked with a clean profile, I'm going to close it as "works for me". If you're able to reproduce with Firefox 2.0.0.3 or later using a new profile, please reopen with detailed steps.

http://kb.mozillazine.org/Profile_Manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.