Default search cannot run on PostgreSQL because of JOIN problems

RESOLVED DUPLICATE of bug 251960

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED DUPLICATE of bug 251960
13 years ago
13 years ago

People

(Reporter: Max Kanat-Alexander, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
If I go to query.cgi on PostgreSQL and I click 'Search' without changing
anything, I get the following error:

DBD::Pg::st execute failed: ERROR: 

JOIN/ON clause refers to "bugs", which is not part of JOIN 

[for Statement "SELECT bugs.bug_id, bugs.bug_severity, bugs.priority,
bugs.bug_status, bugs.resolution, map_products.name, bugs.bug_severity,
bugs.priority, bugs.rep_platform, map_assigned_to.login_name, bugs.bug_status,
bugs.resolution, bugs.short_desc FROM bugs, profiles AS map_assigned_to,
products AS map_products  LEFT JOIN priority ON (priority.value = bugs.priority)
AND (priority.value = bugs.priority) LEFT JOIN bug_status ON (bug_status.value =
bugs.bug_status) AND (bug_status.value = bugs.bug_status) AND (bug_status.value
= bugs.bug_status) LEFT JOIN bug_group_map  ON bug_group_map.bug_id =
bugs.bug_id  AND bug_group_map.group_id NOT IN (3,7,10,5,1,8,11,4,2,6,9)  LEFT
JOIN cc ON cc.bug_id = bugs.bug_id AND cc.who = 1 WHERE bugs.assigned_to =
map_assigned_to.userid AND bugs.product_id = map_products.id AND
((bugs.bug_status IN ('NEW','ASSIGNED','REOPENED'))) AND
((bug_group_map.group_id IS NULL)    OR (bugs.reporter_accessible = 1 AND
bugs.reporter = 1)     OR (bugs.cclist_accessible = 1 AND cc.who IS NOT NULL)  
  OR (bugs.assigned_to = 1) ) GROUP BY bugs.bug_id ORDER BY priority.sortkey
,priority.value ,bug_status.sortkey ,bug_status.value ,bug_status.sortkey
,bug_status.value ,bugs.short_desc ,map_assigned_to.login_name
,bug_status.sortkey ,bug_status.value ,priority.sortkey ,priority.value
,map_assigned_to.login_name ,bugs.bug_id "] 

at /var/www/html/dbinstall/buglist.cgi line 798
(Reporter)

Updated

13 years ago
Target Milestone: --- → Bugzilla 2.20

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 251960 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Bugzilla 2.20 → ---
You need to log in before you can comment on or make changes to this bug.