Date-based group by sort causes invisible messages

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Ed Holden, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When you sort by date and then group by sort, deleteing the last message in the
lowest group (e.g., Today) causes the bottom message in the next higher group
(e.g., Yesterday) to vanish when the lower group disappears.  The message still
exists, as you can leave the folder and then return to it to find the bottom
message back where it belongs.  I will add a series of screenshots to
illustrate.  This seems to happen on the Linux version as well, though I did
this test on Windows XP.  The folders in question are IMAP folders.

Reproducible: Always

Steps to Reproduce:
1. Sort by date, group by sort.
2. Get your folder set up such that one message is grouped under Today and more
than one is under Yesterday.
3. Delete the Today message.  The entire Today group will vanish as expected,
but the bottom message in Yesteday will be sucked away with it (though it is not
really gone).

Actual Results:  
A non-deleted message disappered from under Yesterday.

Expected Results:  
The Today message, along with the entire Today category, should have disappered
... but nothing else.
(Reporter)

Comment 1

13 years ago
Created attachment 176891 [details]
Three-step view  of the group-by-sort problem

This image shows the problem.  In the top view, there is one message grouped
under Today and a few under Yesterday.	In the middle view, I have deleted the
Today message and you'll notice that the bottom Yesterday message has
disappeared with the Today group.  This obivously shouldn't happen.  In the
bottom view I have left the folder and then come back to discover the bottom
Yesterday message, seen in the top view, has miraculously returned.

Comment 2

13 years ago
WFM after several attempts using version 1.0+ (20050616)

Ed, Please try a more recent release
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/1.0.5/ or
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/1.1a1/

Reopen the bug if problem persists.
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 3

13 years ago
wrong resolution, sorry for spammage
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 4

13 years ago
better
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
It works for me as well.  1.0.5 no longer shows this behavior, so I'd call it
resolved.  Thanks!  And great feature!
You need to log in before you can comment on or make changes to this bug.