Closed Bug 285520 Opened 17 years ago Closed 12 years ago

Form manager makes very bad choices for form elements, causing many clashes

Categories

(Toolkit :: Form Manager, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: craig, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041217

The form manager stores many items in an inintuitive way which clashes.
eg. It has more than 10 different things stored as my "State", many of which are
nothing to do with where I am at all. It has almost 10 things stored as my First
Name, only one of which is correct.

Reproducible: Always

Steps to Reproduce:
1. Go to www.opinionplace.com and click on the survey link.
2. Enter an AADVANTAGE#
3. Let the form manager store it (if it can this version -- seems to be random
as to whether that works!) or retrieve it.

Actual Results:  
AADVANTAGE# stored as "Name.First"!

Expected Results:  
Create a URL-specific field to store the AADVANTAGE#.

The field is called "uid", it's obviously a user ID, yet the Form Manager labels
it Name.First? This is just one example of many, and causes lots of silly results.

I'd be happiest of the Form Manager stored items totally by site, since its
attempts at crossing over from one site to another are so random.
Agreed... I've run into this every single time I try to use the thing (causing
me to just give up and not use it).

Dveditz, are you actually working on this code, nowadays?  If not, who is?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have never worked on the suite form manager.
Er... are there multiple form managers?  In that case, why is this a Core
component (and why is dveditz default assignee)?
core used to be browser, this component probably should have been moved to the
application suite product. file a bug and we'll see when we can get someone to
do a proper move, or i can schedule a noisy move for a weekend.
Assignee: dveditz → nobody
Product: Core → Toolkit
QA Contact: form.manager
The old Suite Form Manager no longer exists.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.