Automatic check for new mail, does now check IMAP subfolders

RESOLVED INVALID

Status

Thunderbird
General
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Tom Sommer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

When Thunderbird checks for new mail every X minutes, it does not check IMAP
subfolders for new messages, as it does when first opening Thunderbird.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird 
2. Let startup check for new mail, run
3. Make sure a new mail has landed in one of the the IMAP subfolders (place the
mail in the folder on the server-side)
4. Wait for automatic mailcheck to kick in
Actual Results:  
Thunderbird will not detect the new mail in the folder

Expected Results:  
Thunderbird should highlight the folder as to have received a new mail

You have to close and open Thunderbird again, for it to highlight the subfolder
in the list.

Comment 1

13 years ago
Works for me. Courier-IMAP server.

Is message checking enabled for that folder?

[folder]->context menu->properties->[x] Check this folder for new messages
(Reporter)

Comment 2

13 years ago
Talk about hidden feature, I thought it would naturally check all subfolders,
and you didn't need to mark them one by one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.