Closed Bug 285583 Opened 16 years ago Closed 16 years ago

htmlarea wysiwyg editor broken - regression

Categories

(SeaMonkey :: Composer, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 284245

People

(Reporter: olivier.vit, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050306
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050306

Editing text will fail with

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIDOMNSHTMLDocument.execCommand]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://www.dynarch.com/demos/htmlarea/htmlarea.js :: anonymous :: line 1633" 
data: no]
Source File: http://www.dynarch.com/demos/htmlarea/htmlarea.js
Line: 1633

Works fine in 1.7.3 and Firefox 1.0

Reproducible: Always

Steps to Reproduce:
1. go to the htmlarea demo page
http://www.dynarch.com/demos/htmlarea/examples/core.html
2. select some characters, apply "bold"


Actual Results:  
nothing happens, except the exception in Javascript Console

Expected Results:  
should apply changes and allow text input

When you try to input new text, you get "link found"/"link not found" texts in
the status bar
updated version
Version: unspecified → Trunk
other exception in similar context

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
http://www.dynarch.com/demos/htmlarea/htmlarea.js :: anonymous :: line 1006" 
data: no]
-> Composer

Olivier: Could you reproduce bug in Suite 1.8 beta 1 or specify regression
window (for example between 1.8 alpha 2 and 3)?
Assignee: general → composer
Component: General → Composer
QA Contact: general

*** This bug has been marked as a duplicate of 284245 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.