margin-left value incorrectly rendered in <ul> and <ol> elements

RESOLVED DUPLICATE of bug 27851

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 27851
13 years ago
13 years ago

People

(Reporter: rttlebox, Assigned: dbaron)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Firefox1 and Netscape7 both seem to render tags of the form:
<ul style="margin-left:3ex;"><li>Item</li></ul> 
the same as tags of the form: 
<ul><li style="margin-left:3ex;">Item</li></ul>

I'm not sure if this is technically correct, but it is both different from what
IE6 and Opera7 do, and less flexible than what they do.


Reproducible: Always

Steps to Reproduce:
1.Look at the page above in IE or Opera, and compare the rendering differences
with Firefox's rendering.
2.
3.

Actual Results:  
<ul> left-margin adjustments offset from the default indentation of the list.

Expected Results:  
<ul> left-margin adjustments should overide the default indentation of the list.

Updated

13 years ago
Assignee: firefox → dbaron
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.7 Branch
(Assignee)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 27851 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.