ERROR: Extension System Warning: Failed to set up default extensions files

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Jari Aalto, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)

After complete wipe out and reinstall, the firefox gives always this warning. In
the program (started as regular user) this means that extensions cannot be
installed (in fact you can hit the "install" button, then wait a while, but the
dialog box that shoudl list the extension opens as empty). With root user this
error is not displayed.

What exactly is fifox searching? The error should display the problematic files
or directories so that the cause could be analyzed better.

 *** loading the extensions datasource
Extension System Warning: Failed to set up default extensions files probably
because you do not have write privileges to this location. While you can run
Firefox like this, it is recommended that you run it at least once with
privileges that allow it to generate these initial files to improve start
performance

Technical:

# rm -rf ~/.mozilla /etc/mozilla-firefox/*
# apt-get --purge remove mozilla-firefox
<... then do reinstall >

System/Package: 

Inst mozilla-firefox [1.0.1-2] (1.0.1-2 Debian:unstable)


Reproducible: Always

Comment 1

13 years ago
Did you actually run firefox as root before running it as user?
Does this happen with mozilla.org build?

I /think/ this indicates wrong perms somewhere under profile directory or (more
likely) some items installed globally and no write access in [firefox app
dir]/extensions. The latter should go away after you run once under root though.

I can confirm this if you're specifically asking about including more details in
the error message and not reporting an actual bug in Firefox.
Summary: ERROR: Extension System Warning: Failed to set up default extensions files → ERROR: Extension System Warning: Failed to set up default extensions files
(Reporter)

Comment 2

13 years ago
Yes, I did start firefox as "root" to try to remedy the problem, then switched
to another user and started firefox again and the error persisted.

I have since repeated the process (wipe out + install) and tried
option -ProfileManager and the problem seems to have disappeared. However I have
no idea what caused or cured it.

SUGGESTION

1) Add more details to the error message
2) Display a message where it is suggested that user kills all firefox 
   processes and the re-creates profile with "firefox -ProfileManager"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.