Will not retrieve new mail until mail server restarted

RESOLVED INVALID

Status

MailNews Core
Backend
--
major
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Windows XP Pro SP 2 machines on Windows peer-to-peer network, Thunderbird 1.0.

We are using the Apache James Mail Server (a Java-based STMP/Pop3 mail server,
using 2.2.1 RC 1 version) as our company mail server.  James retrieves mail from
our remote Pop3 accounts every 5 minutes, and distributes the mail to local
mailboxes on our (Windows) network server.

Each client computer on the network uses Outlook as an email client to send and
retrieve mail from James.  Works great, no problems.  We generally run James 24
hours, and shut it down on weekends.

We would like to replace Outlook with Thunderbird 1.0.  The problem is that
Thunderbird will retrieve email on its first connection, but will not retrieve
email from James thereafter unless we shut down and restart James.

Start up James, retrieve email using Thunderbird.  Try to manually or
automatically retrieve email later, "no new messages on server".  We can try
again 10 minutes later, or a day later, still "no new messages".  Shut down and
restart James, Thunderbird retrieves the stored email -- but only up to the
time/date that James was restarted.  This occurs whether we attempt to get all
accounts, or get just specific accounts.

So if we last retrieved mail using Thunderbird on Monday, restart James on
Tuesday morning, and retrieve mail using Thunderbird on Thursday, only the mail
up to Tuesday morning is retrieved. Yet Outlook retrieves new mail without any
need to restart James.


Reproducible: Always

Steps to Reproduce:
1. Start James and deliver mail to mailboxes
2. Retrieve mail using Thunderbird
3. Later attempt to retrieve later-delivered mail: "no new messages"
4. Stop/restart James server; Thunderbird will retrieve new mail 



Expected Results:  
Retrieve the mail

We leave messages on the server for about 20 days. Users on the network retrieve
mail at different times during the day so a copy of a single message may be
retrieved several times.

MS Outlook on the client machines work fine without having to restart James.
Would be interesting to compare the communication between James and Outlook as
compared with James and Thunderbird.
(Assignee)

Comment 1

13 years ago
you're using thunderbird as a pop3 client? In that case, a pop3 protocol log
would be most interesting. Replace <protocol> with pop3 in the following
instructions:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Assignee: sspitzer → bienvenu
(Assignee)

Comment 2

13 years ago
after some e-mail correspondance, this is a server problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.