NOT(integer) not supported by postgres

RESOLVED FIXED in Bugzilla 2.20

Status

()

P1
normal
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Tomas.Kopal, Assigned: Tomas.Kopal)

Tracking

unspecified
Bugzilla 2.20
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
There are two places in bugzilla where we do NOT(integer variable). Postgres is
complaining that the parameter to NOT must be boolean.
Patch follows.
(Assignee)

Comment 1

14 years ago
Posted patch V1Splinter Review
Attachment #177070 - Flags: review?(mkanat)
(Assignee)

Updated

14 years ago
Blocks: 182136

Updated

14 years ago
Attachment #177070 - Flags: review?(mkanat) → review+

Updated

14 years ago
Flags: approval?
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.20
Flags: approval? → approval+
Checking in CGI.pl;
/cvsroot/mozilla/webtools/bugzilla/CGI.pl,v  <--  CGI.pl
new revision: 1.234; previous revision: 1.233
done
Checking in editproducts.cgi;
/cvsroot/mozilla/webtools/bugzilla/editproducts.cgi,v  <--  editproducts.cgi
new revision: 1.72; previous revision: 1.71
done
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 266191 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.