Add attachment of a txt file or jpg. Receipient recieves all attachments in the message body

RESOLVED DUPLICATE of bug 65794

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 65794
13 years ago
13 years ago

People

(Reporter: Bruce Prager, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

If you try and send word, text or jpg attachments in thunderbird, the receipient
recieves all the attachments inline (in the body of the message).
Doesn't seem to be any option to prevent this.
This makes using thunderbird to exchange documents impossible

Reproducible: Always

Steps to Reproduce:
1.Create mail
2.Add word or text file as attachment.
3.Mail to someone with OE, Outlook, etc
4.

Actual Results:  
Mail will have the attachments embedded in the message, rather than as atttachments.

Expected Results:  
Mail should have the attachments as attachments, not imbedded in the body of the
message

Comment 1

13 years ago
See the status whiteboard at the bug for workarounds.

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
The issue is not the hacked work around as suggested in the whiteboard.  This 
is supposed to be a REAL mail program.  Attachments have been around for a long 
time and no one but this program attaches them inline by default.
This bug has been around for over 3 years!!

If its not going to be fixed, then it should be announced so people can 
evaluate the quality of this product. Otherwise, don't refer people to 
whiteboard status and mark 50 bugs as duplicates of each other for 3 years.

Fix the problem!!!!!!!!!!  IT IS NOT RESOLVED under you publish a build that 
attaches attachements properly.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago
Bruce: it's a shame, especially because It's not a matter of doing any coding:
it only needs changing a default value of a parameter. I suggest you also
advocate this on mozillazine's forum. I have tried on a couple of threads;
apparently this is not a big enough issue. 

Comment 4

13 years ago
Re-resolving. Follow the discussion in the other bug report.

(In reply to comment #2)
> Otherwise, don't refer people to 
> whiteboard status and mark 50 bugs as duplicates of each other for 3 years.

There is no need for a new bug. I know it is an old issue, but I'm doing only QA
to manage the reports. Shouting and insulting people does not help anyone! You
can provide a patch or money if you want to help but please don't offend
volunteers which maintain this FREE application.

> Fix the problem!!!!!!!!!!  IT IS NOT RESOLVED under you publish a build that 
> attaches attachements properly.
Shouting never helps.

Please read http://bugzilla.mozilla.org/page.cgi?id=etiquette.html and
http://www.mozilla.org/quality/bug-writing-guidelines.html. Thanks.


*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

13 years ago
> Fix the problem!!!!!!!!!!  IT IS NOT RESOLVED under you publish a build that 
> attaches attachements properly.
Shouting never helps.


Apparently, neither does reporting a serious bug for 3 years. You mention this 
is a FREE application.  If that's the excuse, then I suggest you rewrite your 
web pages for Firefox and Thunderbird and clearly indicate that the 
applications quality is on par with std freeware.  You make a clear case on 
your sites that this is a commercial quality program ready for general use and 
distribution, yet a 1.01 release of your mail program, can't handle 
attachements properly. A bug you admit is well known.
How anyone could have decided that such a bug allows for a release of a 1.0 and 
a 1.01 release is beyond me.
You need to log in before you can comment on or make changes to this bug.