DHTML menus appear underneath Flash plugin movies even when Macromedia's workaround (inserting a WMODE=TRANSPARENT parameter into EMBED and OBJECT areas) is inserted.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Mike of the Cincinnati Mikes, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

DHTML menus will appear underneath a Flash movie that has been embedded in a
page, regardless of z-indexing (because it is not a z-indexing issue, but a
combination of browser type and how that browser handles plugins).  Macromedia
has acknowledged this issue in the following URL: 
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_15523

However, this workaround does NOT work in Firefox.  It DOES work in Internet
Explorer, Netscape 6/7, Safari and others.

Reproducible: Always

Steps to Reproduce:
1.Insert a Flash movie into a page near a DHTML menu.
2. Set WMODE="TRANSPARENT" parameter for both the OBJECT and EMBED tags
3. Activate DHTML menu --it will appear underneath Flash movie instead of over
top, but ONLY in Firefox.



Expected Results:  
The WMODE parameter should have allowed the DHTML menu to appear over top the
flash movie.  If nothing else, Firefox should be designed to instead recognize
the OBJECT tag and not the deprecated EMBED tag, and then allow for the movie to
appear underneath DHTML menus using z-indexing or some other technique.

Comment 1

13 years ago
How about a testcase or an url showing the problem?

Comment 2

13 years ago
Firefox does recognize the object tag, here is an example on how to show a flash
with the object tag:
http://ln.hixie.ch/?start=1081798064&count=1

This is WFM, please reopen if you have an url or a testcase showing this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

13 years ago
Please give a reason instead of just reopening the bug.
(Reporter)

Comment 4

13 years ago
(In reply to comment #2)
> Firefox does recognize the object tag, here is an example on how to show a flash
> with the object tag:
> http://ln.hixie.ch/?start=1081798064&count=1
> 
> This is WFM, please reopen if you have an url or a testcase showing this issue.

Example URL can be found at:
http://www.schaeffersresearch.com/shop/

Please note the flash movie that appears just underneath the main navigation. 
When you click on the arrow buttons next to the tabs along the top, they produce
a DHTML menu...but those menus are appearing underneath the Flash in Firefox. 
But in Internet Explorer, the DHTML menus appear over top the Flash as expected.
 They also appear over top on Netscape versions 6 and 7.  This appears to be a
Firefox-only related issue.  Usually the method of getting around this bug is to
set the WMODE parameter to "transparent," but this has no effect in Firefox.

Comment 5

13 years ago
(In reply to comment #4)
> This appears to be a Firefox-only related issue.

Did you try with a nightly trunkd build as i mentioned in comment 2? Also, what
flash version do you have?

(Reporter)

Comment 6

13 years ago
Created attachment 179961 [details]
Screenshot of DHTML menu appearing underneath Flash movie

Attached is screenshot of the DHTML behavior as it appears underneath the Flash
movie in Firefox.  Usually when this occurs, one can set the WMODE parameter to
"transparent" and that fixes the issue in all browsers except, it appears, in
Firefox.

Comment 7

13 years ago
I think just knowing what flash version you have should be enough. Please right
click the flash and see what version y ou have.
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> I think just knowing what flash version you have should be enough. Please right
> click the flash and see what version y ou have.

The movie was exported to be compatible with versions 6.0 and above.  The
article above explains how to insert object tags in an HTML 4.0 environment, but
this is an XHTML environment.  Nevertheless, I tried the example with no change.
 I have since found a number of articles from blogs reporting the same issue
with regard to Firefox and DHTML menus:

http://www.webmasterworld.com/forum104/433.htm

http://www.qesign.com/software/dhtml-menu-making-faq.shtml (read the section
titled, "Why are the menus appearing behind Flash movies?")

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_15523

Comment 9

13 years ago
But exactly what flash version do you have installed. At macromedias website it
says:
* Macromedia Flash Player version 6,0,65,0

Type about:plugins in the url bar and scroll down to Flash to see what version
you have.
(Reporter)

Comment 10

13 years ago
(In reply to comment #9)
> But exactly what flash version do you have installed. At macromedias website it
> says:
> * Macromedia Flash Player version 6,0,65,0
> 
> Type about:plugins in the url bar and scroll down to Flash to see what version
> you have.

I myself have 7,0,19,0.  Testing on various machines, all with 6, 0, 65,0 or above.

Comment 11

13 years ago
I have the same specifications of Flash and the same problem. An example of this
bug can be found here:

http://www.whats-up.uni.cc/ivolve/example/1.0/example1.html

Comment 12

13 years ago
I did quite a bit of testing on this. Doesn't work for me on
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050730 Firefox/1.0.6
(Debian package 1.0.6-2)
File name: libflashplayer.so
Shockwave Flash 7.0 r25

a good and simple test case is
http://www.communitymx.com/content/source/E5141/wmodetrans.htm

Which works fine on Win XP version 1.0.4
    Shockwave Flash 7.0 r19

Also got someone to test it on OSX running version 1.0.6 and it worked for him.
I guess the question is, is it a firefox issue or a flash issue.

Comment 13

13 years ago
(In reply to comment #11)
> I have the same specifications of Flash and the same problem. An example of 
> this bug can be found here:

There is no flash on that page

(In reply to comment #12)
> a good and simple test case is
> http://www.communitymx.com/content/source/E5141/wmodetrans.htm
> 

Mike Taylor, try that url, does the menu appear above or below the flash?

Comment 14

12 years ago
As mentioned in bug 273585, try using wmode="opaque".

https://bugzilla.mozilla.org/show_bug.cgi?id=273585#c16

Comment 15

12 years ago
Created attachment 209483 [details]
screenshot of DHTML menu loading beneath flash (FF1.5/MAC)

http://smartspot.com/smart_moves/

placing the mouse cursor over any of the secondary navigation items (left hand column) spawns a DHTML tool tip. in firefox 1.5 on mac this causes the flash object to disappear. in firefox 1.0x on PC, this error does not occur (i cannot presently test the issue in firefox 1.5 PC).

wmode="transparent", z-index of <object> is less than z-index of <ul>. wmode="opaque" has also been tried, without success.

works in firefox 1.0 PC, IE6 PC, and Safari 1.3.1 (v312.3.1).
does not work in firefox 1.5 mac, or camino 2005122909 (v1.0b2).

additional information:
OS X: 10.3.9
flash: MAC 7,0,24,0

it should be noted that this issue does not occur in all circumstances. the test cases posted in this thread work fine, as do the menus at http://www.sfredportfolio.com/. however, the same menus (suckerfish dropdowns) were implemented at http://www.smartspot.com/playground/ (will be live by EOW) but drop down beneath the flash (see attachment). even then, if the menus are activated before the flash object has finished loading, the flash object will render underneath the menu (until the mouse is moved and the menu is reactivated).
Created attachment 221465 [details]
Showing everything being fine.

Screenshot showing first attachment displaying as expected based on wmode. The 2nd attachment displays as expected. Flash 8. You probably have a corrupted version of the browser or Flash, please uninstall and reinstall both. I deal with these kinds of things as part of my job, and that's usually the cause when things go funky. :-)
WFM Flash 8, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

It'll work in everything but Linux (wmode isn't supported in Linux).

Please reinstall everything and try again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

12 years ago
(In reply to comment #16)
> Created an attachment (id=221465) [edit]
> Showing everything being fine.
> 
> Screenshot showing first attachment displaying as expected based on wmode. The
> 2nd attachment displays as expected. Flash 8. You probably have a corrupted
> version of the browser or Flash, please uninstall and reinstall both. I deal
> with these kinds of things as part of my job, and that's usually the cause when
> things go funky. :-)
> 

FYI --There is no longer any Flash elements in the URL you used as your screenshot.  That's why the drop-down list works now.
You need to log in before you can comment on or make changes to this bug.