Theme restructuring

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Trunk
Thunderbird1.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Assignee)

Description

13 years ago
Stop building the mozilla\themes\classic, fork any remaining files (there are
only a couple). 

Re-organize the theme files placing them under

mail\themes\qute
and
mail\themes\pinstripe

like Firefox.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 1

13 years ago
Created attachment 177160 [details] [diff] [review]
move qute into mozilla\mail\themes\qute

Moves the thunderbird qute theme into mozilla\themes\qute to be consistent with
mozilla\browser and mozilla\toolkit. Stop building mozilla\themes\classic for
Thunderbird.

Hopefully the changes to mozilla\themes\Makefile.in won't break pinstripe while
I get it in order.
(Assignee)

Comment 2

13 years ago
Created attachment 177161 [details] [diff] [review]
qute restructuring part II remove the old skin files

i had to split the patch into two parts to post it
(Assignee)

Comment 3

13 years ago
Created attachment 177171 [details] [diff] [review]
Part I of the pinstripe restructuring

Comment 4

13 years ago
There is a small graphical bug under OSX, which could be related to these patches.

Activity indicator is not well drawn. Instead of getting the small black wheel,
I get a big button.

When I open customize panel, and I drop throbber onto the "icon box", no
problem, it is well drawn.
(Assignee)

Comment 5

13 years ago
yup i haven't finished the pinstripe stuff yet. That's one of the problems
keeping this bug open. 
(Assignee)

Comment 6

13 years ago
Created attachment 177445 [details] [diff] [review]
fix icons in the stand alone message window
(Assignee)

Comment 7

13 years ago
FYI, i'm still trying to figure out why the activity indicator is not getting
drawn correctly. 

Comment 8

13 years ago
Could you replace '-moz-opacity' with 'opacity'?
OS: Windows XP → All
Hardware: PC → All
*** Bug 288191 has been marked as a duplicate of this bug. ***
Scott: I am not sure if this is related, but the Offline icon is missing from
today's Mac trunk build.
(Assignee)

Comment 11

13 years ago
Created attachment 179329 [details] [diff] [review]
the fix

This fixes the missing offline indicator in the status bar and the broken
activity icon in the toolbar. One line change that took way too much time to
find :)
(Assignee)

Comment 12

13 years ago
I believe I've fixed all of the remaining bugs that came out of the re-org.
closing this off. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.