Download Manager increments version numbers of already existing downloads

RESOLVED DUPLICATE of bug 231048

Status

()

RESOLVED DUPLICATE of bug 231048
14 years ago
10 years ago

People

(Reporter: image57, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

If I download any software with the format <appname>-<version#>.<ext> (i.e.
putty-0.57-installer.exe), and I already have the same file in the download
directory, the Download Manager makes it putty-1.57-installer.exe instead of
putty-0.57-installer-1.exe, which is what I would expect.

Reproducible: Always

Steps to Reproduce:
1. Download any file with the above format
2. Re-download it without deleting the first copy
3.

Actual Results:  
Download Manager increments the first number it encounters after the first dash

Expected Results:  
append the dash to the end of the filename before the extension

Comment 1

14 years ago
See Bug 231048 "download manager poorly renames existing files with number suffix"

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.