context menu displays off screen

VERIFIED DUPLICATE of bug 245163

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 245163
13 years ago
12 years ago

People

(Reporter: John Griss, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

I found that the context menu in the browser windows displays differently from a
text-link verses a graphic-link. It seems that the font-size is different for
each type of link. The reason for this is the context-menu when displayed in the
browser window, displays off the screen, thus no allowing you to select the menu
options. This probably would not be an issue till I installed 8-plugins which
expaned my Right-Click Context-Menu.

Reproducible: Always

Steps to Reproduce:
1.
http://www.snapfiles.com/downloadfind.php?st=kill+process&action=s&offset=50&search_action=&lc=1
2. Right-click on a text-link (notice the font-size)
3. Right-click on a graphic-link (notice the font-size)

Actual Results:  
The context-menu size will be different between the two types of links. I do not
know why it just is. I hope this can be verified and fixed.

Expected Results:  
The context-menus should be the same size and the context-menu should always
show within the boundries of the browser window. In addition if the context-menu
has been added to too long to display it should have a scroll capability with
arrows at the top and bottom of the context-menu so all options can be accessed.

I am using W2K using FireFox 1.0.1. I have loaded 8 plugins off the mozilla.org
site. This does not include the basic extention plugins like .WAV or .MP3.
Here is a list:
Last updated: Sat, 12 Mar 2005 03:35:49 GMT

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1

*** Extensions (enabled: 20, disabled: 0):
Adblock 0.5.2.039
FoxyTunes 1.1
Add Bookmark Here 0.5.3
LastTab 1.1
SessionSaver .2 0.2.1.025
SwiftTabs 0.2.1
NextPlease 0.6.1
SpoofStick 1.05
Feedview 0.9
DictionarySearch 0.7
Bandwidth Tester 0.4.1
Disable Targets For Downloads 0.9
downTHEMall! 0.9.4
SwitchProxy Tool 1.3.1
Download Statusbar 0.9.2
Nuke Anything 0.2
Download Sort 2.5.0
AniDisable 1.0
InfoLister 0.7.5
LiveBookmarkThis 0.2

*** Themes (1):
Firefox (default) 2.0

*** Plugins (10):
Mozilla Default Plug-in
RealJukebox NS Plugin
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) 
RealOne Player Version Plugin
Java Plug-in
Adobe Acrobat
Windows Media Player Plug-in Dynamic Link Library
Microsoft (R) DRM
Microsoft® Windows Media Services
Shockwave Flash

*** This bug has been marked as a duplicate of 245163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.