Enhancement - meta search through search bar

RESOLVED DUPLICATE of bug 171383

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 171383
13 years ago
13 years ago

People

(Reporter: choi9999, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Here I propose an idea for meta search capabilities through the search bar.
1) The notion of folders in the search bar along the same lines as folders in
the bookmarks manager has been broached before.
2) If folders in the search bar ever get implemented, this could lead to meta
searches through the search bar.
3) You would give a "meta search folder" (for lack of a better term) an
appropriate descriptor -- say, "Recipes."
4) You would put search engine plugins into the relevant meta search folder --
for "Recipes," "AllRecipes" and "RecipeSource," for instance.
5) To run a meta search, you just scroll on the search bar down to the meta
search folder as you would any other search plugin.
6) When you type a term into the search bar and run a search using that meta
search folder, Firefox pops open a tab for each of the search plugins tied to
that meta search folder and runs a search for the term you typed in on each
respective search engine.

Reproducible: Always
OS: MacOS X → All
Hardware: Macintosh → All

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 171383 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.