Browser crash [@ libflashplayer.so + 0x4a584 (0x419af584)]

RESOLVED DUPLICATE of bug 200511

Status

--
critical
RESOLVED DUPLICATE of bug 200511
14 years ago
3 years ago

People

(Reporter: solovam, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Hit the URL, observe crash

Reproducible: Always

Steps to Reproduce:
1. Hit the URL
2. Watch it crash
3.

Actual Results:  
Crash

Expected Results:  
Well...

Mozilla 1.7.5 has the same problem
*** Bug 285838 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050311
Firefox/1.0+

Comment 3

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050312
Firefox/1.0+

WFM

Comment 4

14 years ago
Anton Solovyev: Could you provide Talkback incident id of your crash?
Keywords: crash
(Reporter)

Comment 6

14 years ago
Well, since the stack trace mentions flash player, I installed the most recent
one and the problem is gone. I think it can be closed.

Comment 7

14 years ago
Incident ID: 4322224
Stack Signature	libflashplayer.so + 0x4a584 (0x419af584) ee683b10
Product ID	Firefox10
Build ID	2005022519
Trigger Time	2005-03-13 13:57:57.0
Platform	LinuxIntel
Operating System	Linux 2.4.20-20.9
Module	libflashplayer.so + (0004a584)
URL visited	
User Comments	
Since Last Crash	4 sec
Total Uptime	7 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libflashplayer.so + 0x4a584 (0x419af584)
libflashplayer.so + 0x113679 (0x41a78679)
libflashplayer.so + 0x111009 (0x41a76009)
libflashplayer.so + 0xd8517 (0x41a3d517)
libflashplayer.so + 0xbc304 (0x41a21304)
libflashplayer.so + 0xb5d26 (0x41a1ad26)
libflashplayer.so + 0xa849c (0x41a0d49c)
libflashplayer.so + 0x9c654 (0x41a01654)
libflashplayer.so + 0xc027c (0x41a2527c)
libflashplayer.so + 0xc0247 (0x41a25247)
libflashplayer.so + 0xcb6d8 (0x41a306d8)
libflashplayer.so + 0x11bc29 (0x41a80c29)
libflashplayer.so + 0x119b10 (0x41a7eb10)
ns4xPluginStreamListener::OnDataAvailable() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp,
line 544]
nsPluginStreamListenerPeer::OnDataAvailable() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 2220]
nsStreamListenerTee::OnDataAvailable() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsStreamListenerTee.cpp,
line 704]
nsHttpChannel::OnDataAvailable() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 3758]
nsInputStreamPump::OnStateTransfer() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 436]
nsInputStreamPump::OnInputStreamReady() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 337]
nsInputStreamReadyEvent::EventHandler()
PL_HandleEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 402]
event_processor_callback() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x43ddf (0x40599ddf)
libglib-2.0.so.0 + 0x22b35 (0x40578b35)
libglib-2.0.so.0 + 0x23b78 (0x40579b78)
libglib-2.0.so.0 + 0x23e8d (0x40579e8d)
libglib-2.0.so.0 + 0x2458f (0x4057a58f)
libgtk-x11-2.0.so.0 + 0xd3f5f (0x4029ff5f)
nsAppShell::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x15a47 (0x4091ba47)
Assignee: firefox → nobody
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: Browser crash → Browser crash [@ libflashplayer.so + 0x4a584 (0x419af584)]
Whiteboard: DUPEME
Version: unspecified → 1.7 Branch

Comment 8

14 years ago
Anton if it is fixed, could you please mark as Complete - Invalid.  I don't see
why we need to take this any further.Thanks!
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

14 years ago
Closing the case. The problem is resolved by flash plugin upgrade. Apparentlyit
was a bug in flash plugin.
(Reporter)

Comment 10

14 years ago
Thanks to everybody who looked at this. Really appreciate it.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Target Milestone: --- → 2004
Version: 1.7 Branch → 6.x
(Assignee)

Updated

8 years ago
Crash Signature: [@ libflashplayer.so + 0x4a584 (0x419af584)]

Comment 12

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2004 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.