The profile manager should have the same icon than in TB

VERIFIED FIXED in mozilla1.8.1

Status

()

Toolkit
Startup and Profile System
--
enhancement
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: NicolasWeb, Assigned: whimboo)

Tracking

({fixed1.8.1})

Trunk
mozilla1.8.1
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.6) Gecko/20050226 Firefox/1.0.1

-

Reproducible: Always

Comment 1

14 years ago
What? This bug report doesn't make any sense as it stands. Can you clarify?
(Reporter)

Comment 2

14 years ago
Created attachment 177229 [details]
Screen shots

Left Firefox
Right Thunderbird

The same icon for profiles, sorry !
I'v attached files to explain.

Comment 3

14 years ago
The profile manager UI is not an important part of Firefox. WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Comment on attachment 185735 [details]
new icon

This needs to be addressed on a licensing level as I don't know if Qute has
ever been truly tri-licensed, nothing was announced that I can find.  Maybe
email mscott and see if we can swipe the icon or not.  Otherwise, you could
always ask Stephen Horlander if he'll design a new icon, which might be
preferable, but this is all utterly non-critical since this feature only still
exists for the benefit of testers and developers.
Attachment #185735 - Flags: review?(mconnor)
(Assignee)

Comment 6

13 years ago
I have spoken with Arvid Axelsson who creates Qute. He has given approval for
using the 'profileicon.png' within the profile manager of Firefox. 

It is a major must have for the profile manager UI. Multiple applications using
the same frontend should mostly look identically in every part. Since it's
allowed now we are able to port this to Fx profile manager.

A patch is upcoming immediately.
Status: RESOLVED → UNCONFIRMED
OS: Windows XP → All
Resolution: WONTFIX → ---
(Assignee)

Comment 7

13 years ago
Created attachment 197061 [details] [diff] [review]
Port of profileicon.png from tb profile manager

This is the port from the profile manager of Thunderbird for Firefox. If this
patch should ever been applied, the profileicon.png for Winstripe and Pinstripe
have to be updated and profileicon.gif in Winstripe deleted.
Assignee: benjamin → hskupin
Status: UNCONFIRMED → ASSIGNED
Attachment #197061 - Flags: review?(mconnor)
(Assignee)

Comment 8

13 years ago
Kevin, are you fine with that icon or do you wanna see an icon designed from you
here?

Updated

13 years ago
Attachment #185735 - Attachment is patch: false
Attachment #185735 - Attachment mime type: text/plain → image/png
Comment on attachment 197061 [details] [diff] [review]
Port of profileicon.png from tb profile manager

ok, its definitely a lot nicer icon, though Profile Manager is basically unsupported except for testers/devs. 

Also, tb/fx have significantly different themes, so your argument there is fairly weak, unless Winstripe Tbird were to suddenly get switched out.
Attachment #197061 - Flags: review?(mconnor) → review+

Updated

13 years ago
Whiteboard: [checkin needed]
mozilla/toolkit/themes/pinstripe/mozapps/profile/profileicon.png
new revision: 1.3; previous revision: 1.2
mozilla/toolkit/themes/winstripe/mozapps/jar.mn
new revision: 1.11; previous revision: 1.10
mozilla/toolkit/themes/winstripe/mozapps/profile/profileSelection.css
new revision: 1.3; previous revision: 1.2
mozilla/toolkit/themes/winstripe/mozapps/profile/profileicon.gif
new revision: delete; previous revision: 1.2
mozilla/toolkit/themes/winstripe/mozapps/profile/profileicon.png
initial revision: 1.1
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago13 years ago
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.6-
Version: unspecified → Trunk
I forgot to credit Henrik in the check comment, my apologies!

Comment 12

13 years ago
The pinstripe icon didn't need an update. Gavin, can you please back the change to mozilla/toolkit/themes/pinstripe/mozapps/profile/profileicon.png out?
(In reply to comment #12)
> The pinstripe icon didn't need an update. Gavin, can you please back the change
> to mozilla/toolkit/themes/pinstripe/mozapps/profile/profileicon.png out?

Sure, I'll back it out. It looks like the same "old" icon as with Winstripe, though, why doesn't it need the change?

Comment 14

13 years ago
(In reply to comment #13)
> Sure, I'll back it out. It looks like the same "old" icon as with Winstripe,
> though, why doesn't it need the change?

It's similar to the Winstripe icon, but not the same. I added the silhouette icon to Pinstripe deliberately a while back. Also the new icon style doesn't follow either FF or TB's style on the Mac.
(Assignee)

Comment 15

13 years ago
(In reply to comment #11)
> I forgot to credit Henrik in the check comment, my apologies!

Not a problem, Gavin. It looks much nicer now.

v.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Attachment #197061 - Flags: approval1.8.1? → branch-1.8.1+
Landed on the 1.8 branch.
mozilla/toolkit/themes/winstripe/mozapps/jar.mn;                         1.9.2.1;
mozilla/toolkit/themes/winstripe/mozapps/profile/profileSelection.css;  1.2.26.1;
mozilla/toolkit/themes/winstripe/mozapps/profile/Attic/profileicon.gif;   delete;
Keywords: fixed1.8.1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.