[REGRESSION]select form control is not displayed if the SELECT tag has the MULTIPLE attribute.

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Matt Bissiri, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fixed - just need to check it in)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
To reproduce:
load a page that has a SELECT tag with the MULTIPLE attribute.

Actual result:
on linux, a vertical scrollbar is displayed instead of the select,
on win32, the select is not displayed.
I have not tried this on mac.

Expected result:
The select form control should be displayed normally.

Build dates and platforms:

SELECT with MULTIPLE is displayed correctly with these builds:
mozilla m13 release linux rh6.1 gnome/e
2000-02-11-11-M14 linux rh6.1 gnome/e
2000-02-11-09-M14 win32 NT4

SELECT with MULTIPLE is displayed incorrectly with these builds:
2000-02-12-17-M14 win32 NT4
2000-02-13-09-M14 win32 NT4
2000-02-13-17-M14 linux rh6.1 gnome/e
2000-02-14-09-M14 linux rh6.1 gnome/e
2000-02-17-15-M14 linux rh6.1 gnome/e

Additional information:
If the select tag does not have the multiple attribute, the select form control
is displayed correctly.
(Reporter)

Comment 1

18 years ago
Created attachment 5516 [details]
testcase for bug 28593
(Reporter)

Updated

18 years ago
Keywords: testcase
(Reporter)

Comment 2

18 years ago
I'm starting to debug this, maybe the problem is here:
layout/html/style/src/nsCSSFrameConstructor.cpp
in this function: nsCSSFrameConstructor::ConstructSelectFrame
trouble with the #ifdef's ?

http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp&rev=&root=/cvsroot

maybe the problem is related to nsCSSFrameConstructor.cpp rev 1.354 (fix for
27253)?

I uncommented this line (my source tree is latest source from feb 18):
//#define NEWGFX_LIST
and rebuilt libraptorhtml.so, then bug 28593 does not seem to appear.
(Reporter)

Updated

18 years ago
Blocks: 28143

Comment 3

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods
(Assignee)

Comment 4

18 years ago
No, we definitely want NEWGFX_LIST set to undefined, that will introduce way 
many more bugs. This is a regression
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: testcase → beta1
Summary: select form control is not displayed if the SELECT tag has the MULTIPLE attribute. → [REGRESSION]select form control is not displayed if the SELECT tag has the MULTIPLE attribute.
Whiteboard: fix is in my tree
(Assignee)

Comment 5

18 years ago
Created attachment 5542 [details]
simple testcase

Comment 6

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: fix is in my tree → [PDT+]fix is in my tree

Comment 7

18 years ago
Please give us ETA for fix date check in in Status Whiteboard..thanks!
(Assignee)

Comment 8

18 years ago
Finishing up the testing of the fix.
Whiteboard: [PDT+]fix is in my tree → [PDT+] fix 2/28
(Assignee)

Comment 9

18 years ago
updated status
Whiteboard: [PDT+] fix 2/28 → [PDT+] fix 3/1
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] fix 3/1 → [PDT+] fixed - just need to check it in
(Assignee)

Comment 10

18 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Marking VERIFIED FIXED on:
- Linux6 2000-03-06-09 Commercial build
- MacOS9 2000-03-06-08 Mozilla build
- Win98 2000-03-05-17 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.