Status

NSPR
NSPR
--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Tracking

({regression})

x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
With the 2005-03-09-06 Mozilla build logging works, with the build from
2005-03-10-05 logging is broken. I tried the modules NSPR_LOG_MODULES=NNTP:5 and
NSPR_LOG_MODULES=SMTP:5 (together with set NSPR_LOG_FILE=c:\log.log). With the
build from 10th, only a empty log file with 0 bytes is created. OS is Windows
2000, but this also broke under Linux with xterm. I think the patch from Bug
255633 caused this, CCing patch author.
(Assignee)

Comment 1

13 years ago
Created attachment 177273 [details] [diff] [review]
Patch

Problem was the -, in [ ] a - means a range of chars (here it was from 9 to _).
So we ended up with something like module="NNTP:5" instead of module="NNTP".
Assignee: wtchang → bugzilla
Status: NEW → ASSIGNED
Attachment #177273 - Flags: review?(wtchang)
ccing wtc, since he checked in the code in question (and what he checked in is
_not_ the same as what's attached to bug 255633).

Comment 3

13 years ago
Comment on attachment 177273 [details] [diff] [review]
Patch

I am sorry that I checked in a patch without
testing.

I moved the location of '-' in the original
patch, not realizing that '-' may be a special
character in a scanset in some implementations.

For maximum portability, I can't assume that
'-' can be used to specify a range of characters
in a scanset.  This is the only reason I rejected
this patch.

I will fix this bug by moving '-' to the end of
the scansets.
Attachment #177273 - Flags: review?(wtchang) → review-

Comment 4

13 years ago
I checked in a fix on the NSPR trunk (NSPR 4.6) and
NSPRPUB_PRE_4_2_CLIENT_BRANCH (Mozilla 1.8 Beta 2).
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.6
You need to log in before you can comment on or make changes to this bug.