Crash with tr:hover, td:hover position:fixed on this Java applet testcase

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
14 years ago
9 months ago

People

(Reporter: martijn.martijn, Assigned: roc)

Tracking

({crash, testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b2 -
blocking1.8b3 -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments, 1 obsolete attachment)

Reporter

Description

14 years ago
See upcoming testcase. the java .class file comes from the url I gave here above.

Talkback ID's:
TB4322254W, TB4321921G and TB4321837Z
They all show something different.

I actually don't know what the right component of this bug should be.
Reporter

Comment 2

14 years ago
Posted file Testcase (obsolete) —
Quickly hovering over the java file (or the text) should trigger the crash. (it
does for me within 10 times hovering over it).
Reporter

Comment 3

14 years ago
Hmm, forget about the testcase, the java file doesn't seem to run in bugzilla.
But this one works (and crashes Mozilla when quickly hovering over the applet): 
http://wargers.org/test/mozilla/crash/286004_java.htm
Reporter

Comment 4

14 years ago
Forgot to mention, it seems to have something to do with this applet, I haven't
been able to crash with a different applet.
Reporter

Comment 5

14 years ago
Also crashes Mozilla1.7 and Mozilla1.4.
Severity: normal → critical
Keywords: crash

Comment 6

14 years ago
Posted file java console log
Using Java 1.5.0_01, I can crash trunk sm as well although not consistently and
the stacks are all different. The attached java console log shows the initial
page load up through the liveconnect: the url... line 13. Afterwards the
console messages are for moving the mouse over the text/page rapidly. It
sometimes crashes at around the "basic: Done ..." lines.
Martijn, do you still crash if you use nested divs (with "div { position: fixed
}") instead of using a table?
Reporter

Comment 8

14 years ago
Yes, in fact only one div with div:hover{position:fixed} is enough for me to crash:
http://wargers.org/test/mozilla/crash/286004_java_div.htm
Want to attach that to this bug?

I assume that's the same crash I see in a debug build unloading the testcase in
bug 283385...
Oh, and this is totally views, looks like...
Assignee: live-connect → roc
Component: Java: Live Connect → Layout: View Rendering
Flags: blocking1.8b2?
QA Contact: pschwartau → ian
Reporter

Comment 11

14 years ago
Posted file Testcase
Ok, this is the same testcase as mentioned in comment 8.
However, for me the Java applet won't load in the bugzilla url.
Attachment #177313 - Attachment is obsolete: true
Reporter

Comment 12

14 years ago
The testcase don't crash directly anymore with 20050318 build (with the fix for
bug 283385 ), but they crash still when you close the tab or visit another url.
Duplicate of bug 285996? We'll see when I land the patch
Reporter

Comment 15

14 years ago
This is not fixed with the fix for bug 285996.
I tried the testcase (at
http://wargers.org/test/mozilla/crash/286004_java_div.htm ) 3 times.
The first time I crashed on reload, the second time Mozilla hanged and the the
third time Mozilla closed directly on hovering.
I just tried lots of hovering and clicking and reloading and it did not crash.

Updated

14 years ago
Flags: blocking1.8b3?
Flags: blocking1.8b2?
Flags: blocking1.8b2-

Comment 17

14 years ago
Martijn, whats the status on this one?, wfm winxp 2005060306
Reporter

Comment 18

14 years ago
Sorry, because of some server issue all my files were wiped :-(
Like I said, you can only try to see if it crashes here:
http://wargers.org/test/mozilla/crash/286004_java_div.htm
The attached testcase at bugzilla won't work, because the Java applet won't load.
The current situation is that it still hangs/freezes my Firefox when quickly
hovering over the testcase. (in the status bar I get messages like "Applet
inited", "Applet started").
Martijn, when I load that URL the page is not found.
Reporter

Comment 20

14 years ago
My provider accidently wiped out my webspace :(
The url should work again, now.

Updated

14 years ago
Flags: blocking1.8b3? → blocking1.8b3-
Blocks: 321106

Comment 21

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060519 Minefield/3.0a1

WFM with Java(TM) Plug-in 1.5.0_06-b05.
Reporter

Comment 22

13 years ago
I still am able to crash with a 2006-05-22 trunk build on winxp, using Java build build 1.5.0_06-b05.
Talkback ID: TB19056511Z
jpinscp.dll + 0x73a1 (0x6d4273a1)
PresShell::EnumeratePlugins   PresShell::Freeze   DocumentViewerImpl::Destroy   DocumentViewerImpl::Show   nsPresContext::EnsureVisible   nsPluginInstanceOwner::Init   nsObjectFrame::PrepareInstanceOwner   nsObjectLoadingContent::Instantiate   0x290a2ebc
0x0249c300
nsAccessibleWrap::AddRef   0x0a75c085
This was after hovering over the testcase a few times and then loading a new page.

Updated

13 years ago
Blocks: 353557

Updated

13 years ago
No longer blocks: 353557
Reporter

Comment 23

13 years ago
After updating to Version 1.5.0 (build 1.5.0_10-b03) of Java, I don't crash anymore with the testcase, so marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.