Printing, font impossibly small if email has a very long line

RESOLVED DUPLICATE of bug 319284

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 319284
13 years ago
12 years ago

People

(Reporter: paul, Assigned: Scott MacGregor)

Tracking

x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla Thunderbird version 1.0 (20041206)

Printing an email with a "long line" in it is ugly. Seems the font 
size used is reduced to whatever size is necessary to allow the "long 
line" to print without wrapping. This often makes printout impossible to 
read. A typical long line is an URL that was pasted into the email. Note that
long line has no embedded spaces.


Reproducible: Always

Steps to Reproduce:
1. Print an email with a very long line in it, with no embedded spaces.
2.
3.

Actual Results:  
Printed in a tiny fon size such that long line fits on one line. Result is
printed message is unreadable because of the tiny font size used.

Expected Results:  
It should print in the defaulf font size and wrap the long line somehow, even if
the long line has no embedded spaces.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0

Comment 1

13 years ago
This is in relation to some wrapping problems.  The workaround for it is to 
either hit the forward button or Message>Edit Message As New.  If the text in 
the body still isn't wrapped, you have to select it & then do Edit>Rewrap.  
Once the text is wrapped properly, the font looks fine when printed.  Some 
bugs related to this are:

Bug #237558
Bug #196033
Bug #249093
Bug #249082

I hope this helps.

Comment 2

12 years ago
As noted at the dupe, Mozilla supports a preference for printing that 
controls this.  It's under File|Page Setup, and there's also a dropdown at 
the top of the print preview window -- changing from "Shrink to Fit" to something like "100%" will get you the desired results.  Changes to the dropdowns persist, so you don't have to keep revisiting it.  

Note that the very wide line will be truncated on output when the print 
scaling is adjusted.

*** This bug has been marked as a duplicate of 319284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
*** Bug 313904 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
*** Bug 288445 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
*** Bug 81750 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.