If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add name and version of community build to user agent string

VERIFIED FIXED in seamonkey1.0alpha

Status

SeaMonkey
General
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Steve Chapel, Assigned: Robert Kaiser)

Tracking

Trunk
seamonkey1.0alpha
Bug Flags:
blocking-seamonkey1.0a +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
See
http://groups-beta.google.com/group/netscape.public.mozilla.seamonkey/msg/dc84db19dbc2a32f?dmode=source
for a description of what the user agent string for the Mozilla Suite community
build should look like. We need to add the name & version of the browser to the
end like so:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20050605 Seamonkey/1.0

Comment 1

13 years ago
Simply use the existing string prefs general.useragent.vendor and
general.useragent.vendorSub for that like Netscape 7.x does.

general.useragent.vendor = Seamonkey
general.useragent.vendorSub = 1.0
(Reporter)

Updated

13 years ago
Blocks: 286066
(Assignee)

Comment 2

13 years ago
Taking, as I consider that part of the rebranding effort and I volunteered to do
the rebranding stuff. Thanks for the pointer what to do :)
Assignee: general → kairo
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1+

Comment 3

13 years ago
I saw this "kairo@kairo.at  	2005-03-25 16:18 PST  	Flag  	    
blocking-aviary1.1+" in comments, but since that field was removed, I am adding
to current one in its stead.
Flags: blocking1.7.7?
(Assignee)

Comment 4

13 years ago
blocking-seamonkey1.0a is what you want :)
...and granted - though I'll fix this with rebranding stuff anyways...
Flags: blocking-seamonkey1.0a+
(Assignee)

Comment 5

13 years ago
Created attachment 178846 [details] [diff] [review]
patch: will be part of rebranding

Here's the patch I'll use.
Note that this doesn't make sense without the rebranding patch, as it would
append another "Mozilla/1.8b2" at the moment, which is not what we want.
Because of that, I'll do this along with the real rebranding stage of bug
285696
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Seamonkey1.0alpha
(Assignee)

Comment 6

13 years ago
Created attachment 180055 [details] [diff] [review]
patch v2: use new pref stuff (still part of rebranding)

Just to tell you hwere we're going, after the latest round of checkins, we'll
go with this approach.
(Assignee)

Updated

13 years ago
Attachment #178846 - Attachment is obsolete: true

Updated

13 years ago
Flags: blocking1.7.7?
(Assignee)

Comment 7

13 years ago
This landed with the stage 2 patch in bug 285696
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED; SeaMonkey 1.0a

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050707
SeaMonkey/1.0a
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.