Checksetup.pl fails on database connection

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Stephen Klein, Assigned: zach)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

Running Windows 2000 Server SP 4 with McAfee A/V client 8.0i controlled by ePO 
server and IIS 5.1.  Downloaded ActivePerl 5.8.2.808 and MySQL 4.1.10a.  Both 
installed just fine.  All configuration changes were made according the 
Bugzilla installation instructions provided online.  Tried to run checksetup.pl 
in step 2.2.3 and received the following error:
---------------------------
Precompiling templates ...
DBI connect(';localhost;3306','bugs',...) failed: Client does not support 
authentication protocol requested by server; consider upgrading MySQL client at 
D:\bugzillafiles\checksetup.pl line 1460
Can't connect to the mysql database.  Is the database installed and up and 
running?  Do you have the correct username and password selected in localconfig?
---------------------------

As I said, I've already followed all of the instructions in the instructions 
provided for installation.  I'm not running Apache, but that shouldn't make a 
difference, because I haven't reached the web server config step yet.

Reproducible: Always

Steps to Reproduce:
1.  Followed instructions for Bugzilla installation.
2.  Skipped section 2.2.2.3 "Permit attachments table to grow beyond 4GB"
3.  Attempted run of checksetup.pl in section 2.2.3 and received error

Actual Results:  
Script fails and returns to command promt.

Expected Results:  
Should connect to MySQL database and finish installation.

Any help available would be appreciated.
Thanks!

Stephen Klein
sklein@sgi-net.com

Comment 1

14 years ago
That sounds like either a bug in the ActiveState DBI or a problem with the MySQL
client libraries that you have installed.

On Linux, I'd say that you didn't compile your DBI against the correct version
of MySQL.
this is covered in the docs -- troubleshooting (appendex B), number 11.

http://www.bugzilla.org/docs/2.18/html/trbl-passwd-encryption.html

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.