Opening word document does not bring MS Word window to top, Firefox stays in foreground.

RESOLVED DUPLICATE of bug 277406

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 277406
13 years ago
13 years ago

People

(Reporter: Pavel Penaz, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050315 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050315 Firefox/1.0+

Opening word document does not bring MS Word window to top, Firefox stays in
foreground. On most web sites this works but on the above testcase it does not

Reproducible: Always

Steps to Reproduce:
1. Go to ftp://downloads1.kaspersky-labs.com/beta/kavpersonal/english/
2. Click on the file release_notes.doc
3. Choose to open the document in MS Word

Actual Results:  
The document opens in MS Word but Firefox window stays in foreground

Expected Results:  
MS Word should load an active window (in the foreground)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050315
Firefox/1.0+

Confirming.
(No time to look for dupes so I won't set it new)
(Reporter)

Comment 2

13 years ago
Strange that I can reproduce this bug with any .doc (MS Excel 2003) or .xls (MS
Excel 2003) but not with .pdf (Acrobat Reader 7.0.1) or .ppt (MS Powerpoint 2003).

Comment 3

13 years ago
Maybe related?

Bugzilla Bug 255123
Opening URL from another app focuses an existing window before opening a new window

Bugzilla Bug 35578
Mailnews should open http/ftp links in new browser window by default
(Reporter)

Comment 4

13 years ago
The oldest build I have access to is Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8a6) Gecko/20050101 Firefox/1.0+ and that build still suffers from
this bug.

Comment 5

13 years ago
I can confirm this bug in both Deer Park Alpha 2 and Mozilla Thunderbird 1.1a2.
Next workaround has been reported to BBS in Japan.
 - At "Opening..." dialog for MS Office file(".doc",".xls",".ppt",...),
   check "Always perform this action when handling files of this type".
   ("Open it with the default application" or "Open it with" is also required)
Does this work?
(Reporter)

Comment 7

13 years ago
I can still see this behaviour with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051028 Firefox/1.6a1

Comment 8

13 years ago
Bug 277406 for Thunderbird, but the patch should work for Firefox.

*** This bug has been marked as a duplicate of 277406 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.