Undeleting RSS a/c stops feed providing text story summary

RESOLVED DUPLICATE of bug 267082

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 267082
13 years ago
9 years ago

People

(Reporter: SwissMac, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

After accidentally deleting an RSS feed account in the left column view, it is
possible to drag it back into place again, but with changed behaviour. Next time
the feed source sends data, the story summary does not show in the bottom right
view pane, although the story title appears as normal in the top right view
pane. This happens every time, and there is nowhere to check on the settings as
for an ordinary email account. I have set the RSS feeds to not collect the whole
story or webpage, just a summary of it.

After deleting the account fully to try to re-sign for the feed, more than one
copy of each message is received.

Having a "Confirm Delete?" dialog box would reduce accidental deletions (I have
done this twice now) but the bug still exists too in both versions 1.0 and in 1.0.1.

Reproducible: Always

Steps to Reproduce:
1. Set up RSS feed and have it working;
2. Highlight account name in left view pane and click on delete button;
3. Drag deleted account from Trash back to its original position.

Actual Results:  
RSS feeds lost their story summary, but kept their title.

Expected Results:  
RSS feeds when "undeleted" should be totally reinstated, so that both summary
and title are received from RSS feed senders. It is too easy to delete an
account without a dialog. After deletion it is impossible to reinstate things as
they were. 

After setting up the old account again, more than one copy of each feed item
were intermittently received (from bbcnews.com). This further indicates a
problem with the account deletion mechanism.
(Reporter)

Comment 1

13 years ago
Just to add clarity to the issue through elimination of similar behaviours, I
dragged a single RSS feed item into Trash then returned it to its original
folder and the test remained. I did the same using the Delete button rather than
d n d and had the same outcome. It has to be the entire account that is dragged
or deleted to Trash to recreate the bug. Oh, and the Trash bin doesn't empty
automatically either, but I guess that's another issue.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 267082 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.