Closed Bug 286380 Opened 15 years ago Closed 15 years ago

chrome.manifest not removed when an extension is uninstalled

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

Attachments

(2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050315 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050315 Firefox/1.0+

It appears that the chrome.manifest file that was introduced by bug 278534 and
bug 283352 didn't include code to remove the chrome.manifest when an extension
is uninstalled (it is removed during an upgrade and then replaced with a new
one) which will then prevent the removal of the directory used by the
uninstalled directory.

Reproducible: Always

Steps to Reproduce:
1. Install, restart, uninstall an extension
Actual Results:  
The chrome.manifest remains

Expected Results:  
The chrome.manifest is removed and thereby allows the code in
nsExtensionManager.js to remove the no longer used directory.
Attached patch patch (obsolete) — Splinter Review
This patch removes the chrome.manifest file when a theme or extension is
uninstalled. There are still issues with uninstalling themes as noted in the
patch due to bug 251026 which prevents a theme from being uninstalled when it
has a preview or icon in its jar.
Assignee: bugs → moz_bugzilla
Status: NEW → ASSIGNED
Attachment #177594 - Flags: review?(benjamin)
Attachment #177594 - Attachment is obsolete: true
Attachment #177594 - Flags: review?(benjamin)
Attached patch patch (fixed indent) (obsolete) — Splinter Review
Attachment #177597 - Flags: review?(benjamin)
Comment on attachment 177597 [details] [diff] [review]
patch (fixed indent)

r=me, however please hold off landing this patch until Ben lands some
semi-significant extension manager reworking
Attachment #177597 - Flags: review?(benjamin) → review+
Not a problem. I suspect that the changes with Ben's patch from bug 286034 will
change the structure as well as flow significantly enough to make this patch as
well as the patch to bug 251026 and bug 252418 at best to not be need since the
functionality can be included in the rewrite and at worse require additional
rewrite of the code if these steps aren't taken into account in the flow.
Should this bug be set as a blocker for Bug 248298 ?
I don't believe it is necessary to do so. I think we will know better after the
patch in bug 286034 is checked in and it does appear that it will fix bug 248298
and this one.
Depends on: eminstall
Fixed by the checkin for bug 286034
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Attachment #177597 - Attachment is obsolete: true
Attachment #177597 - Flags: review+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.