Thunderbird newsreader losing watched threads/labeled messages

RESOLVED DUPLICATE of bug 79988

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 79988
13 years ago
10 months ago

People

(Reporter: Csaba Gabor, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

If I select a thread to watch or label a message as important, when I come back
to Thunderbird some time later (presumably after the message has expired off the
server, days or months later), then the message body (that was once on my PC)
now shows (for example):

Error!
newsgroup server responded:No Such Article In Group
Perhaps the article has expired
<MPG.1c9b85b8660f4fa098a35a@nntp.lucent.com> (345461)
Click here to remove all expired articles

Reproducible: Always

Steps to Reproduce:
Watch a thread or label a message or both.
Then wait for a few days or months
Actual Results:  
Message body is gone.

Expected Results:  
I expect that Thunderbird not destroy data that it has (at my behest) placed on
my PC without so much as a "by your leave".  Especially data (a newsgroup
article) that has clearly and explicitly been marked as significant (important,
 to do, watched, etc.) to the user).

This is something that also happens on Outlook Express.  But I confess that I
must have a real conceptual stumbling block here because I cannot fathom what
program designer would EVER allow something as important as documents,
especially those a user has marked as significant to be (especially willfully)
destroyed.  Or is there some setting I'm missing?

I want to use a newsreader as a glorified filing cabinet.  Ultimately, it will
be possible to conveniently set a set of keywords on a given message/thread and
automatically have it filed/kept as a reference with those associated keywords.
 But until this convenient labelling technology is available, I expect that the
only messages to be removed are those that I am ignoring (ie. Ignore Thread) or
(I) have otherwise expired.

To be explicit, the way I use my newsreader is to scan a few groups that are
relevant to my work.  Every once in a while (say once a day on average) I will
run into an article I consider well written and worth SAVING either for the
example or explanation it provides or the references it has.  These are articles
I DO go back to.  SAVING for me means marking the thread as one to watch (or
possibly labeling the message as important).  Messages not marked thus, I will
eventually ignore when it's clear there are no interesting follow-ups.

I can understand that this may cause a newsreader to be slower if it has to keep
track of massive amounts of dated, thread information.  But that's what
computers are for...let 'me compute.  And if I've managed to bog down my system
so much that it becomes noticable for me, let ME be responsible for putting it
right.

To sum up: 1) The behaviour that I expect of Thunderbird, is that when a
message/thread has been designated as interesting to me in some way (labeled or
thread marked as Watch), then if there is a disk copy, that should be used
(alternately, if there is no server copy, then the disk copy should be used).

2)  If there is some technical reason that I just don't get for why this can't
be done, then I propose an alternative: when a message is being expired (because
it is no longer on the server) but it has been designated as significant in some
way, then have a special folder where expired messages/threads go where the
bodies are retained on the user's PC.

The important thing is to have a way that requires a minimal amount of work from
me (and fiddling with multiple windows, dialog or otherwise, is too much work)
in order to get messages in a reasonable form to their end destination.

Csaba Gabor from Vienna

Tools / Account Settings / Offline & Disk Space has only Keep: All messages
selected.  I have a pretty vanilla setup of Thunderbird.
Sorry, if this has already been filed, but I didn't find it when searching.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

12 years ago
Csaba: does this happen even with messages have downloaded for offline use?

If so, it's bad. Otherwise, given the nature of NG's, I guess it might be
considered consistent behaviour, as such messages are seen as a server side
thing, much like web pages, until downloaded for offline use.

Perhaps you want a feature that automatically downloads messages you mark as
watched/labelled/flagged for offline use (and safekeeping)? That in turn is
still a bit flawed ATM, but better than just losing the messages...

Perhaps what you want can be reached by tweaking existing settings options, try
the Thunderbird newsgroup
snews://secnews.netscape.com:563/netscape.mozilla.thunderbird.
(Reporter)

Comment 3

12 years ago
Thanks for your comments Gudmund,

I do not know the answer to your first question yet - must be tested.  However,
it was useful because I did a test to determine that Thunderbird does not cache
(while online) the messages that you view in a useful way.  That is to say, if
you now go offline, that same message will not be there for you to view.  In
otherwords, online messages are downloaded (else you wouldn't see them at all),
but not (usably) saved.

In light of this, I think your suggestion is excellent: have a preference
setting to download and store any marked/labelled/(possibly even read)/except
ignored messages.  Furthermore, messages marked ignore could be deleted from the
user's disk.

I could not find the newsgroup that you were talking about, though I tried
plunking in that reference in different ways.  The secnews.netscape.com server
shows me the same groups as the news.mozilla.org server.  But neither shows a
netscape.mozilla group to me.  I did however find an old query of mine shown
below.  Is that the group you were talking about?

http://forums.mozillazine.org/viewtopic.php?t=222583&highlight=csaba&sid=55fa248622a5457d50333648b192b298

Csaba Gabor from Vienna

Comment 4

12 years ago
if you pick the newsgroup for offline use, either with the "select folders for
offline use" button, available in the offline & disk space line in account
settings, or from file | offline | download and sync, or through the newsgroup
folder's property dialog, then we will store messages you read for offline use.

Comment 5

12 years ago
using tin, my former news reader, I could save messages off to a local folder whose name was the newsgroup.

suite bug is Bug 184007.

and a number of related bugs:
Bug 79988 (which should probably read "store", not cache)
Bug 105146
Bug 213729
Bug 155828
  	 
Csaba, is one of the above bugs a good match for your needs? And if not, can you refine your summary to better match what you want? 
QA Contact: general

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 79988

Comment 7

10 months ago
This is still an issue as of today, with Thunderbird 45.5.1 on Ubuntu 16.10.
It also doesn't look like a duplicate of the mentioned bug, to me.

Anyway, other newsgroup readers (pan) work just fine.
You need to log in before you can comment on or make changes to this bug.