Cookies and Exceptions List sheets remember search state, but not search

RESOLVED FIXED in Camino1.0

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: bmo, Assigned: mikepinkerton)

Tracking

({polish})

unspecified
Camino1.0
PowerPC
macOS
polish

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
An odd behavior happens with the new search fields in "Show Cookies…" and "Edit
Exceptions List…", wherein it remembers that you last performed a search, but
not what you searched for. It's really just a polish issue (no functional
difference that I can tell), but it merits fixing nonetheless.

Steps to Reproduce:
1. Open Preferences… > Privacy > Show Cookies…
2. Search for something (e.g., .)
3. Click "Done"
4. Open "Show Cookies…" again

Camino doesn't remember the search just performed (as intended, I think), but it
still has a (x) box on the search field, giving the appearance that a search is
being executed. Basically, the search box doesn't seem to have lost its state
entirely.
we should certainly fix this.
Target Milestone: --- → Camino1.0
I think Olivier did the initial work on these nifty search boxes....

Updated

14 years ago
Attachment #178167 - Flags: review? → review?(lordpixel)
looks good and is good for the general case. fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Comment on attachment 178167 [details] [diff] [review]
source to clear the delete button

Removing obsolete request on fixed bug; apologies for bugspam.
Attachment #178167 - Flags: review?(lordpixel)
You need to log in before you can comment on or make changes to this bug.