Many webpages will render properly, and then later 'erase' themselves.

RESOLVED DUPLICATE of bug 272699

Status

--
major
RESOLVED DUPLICATE of bug 272699
14 years ago
14 years ago

People

(Reporter: meyvnheart, Assigned: mikepinkerton)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98)
Build Identifier: 

I've noticed on many Xangas that occasionally when loading certain types of
webpages, they will render properly, and then simply go white when I try to
scroll. Usually, on the Xangas, this does not happen instantly, and only seems
to happen with ones that have songs in teh background, and will occur anywhere
from as soon as the song starts to thirty seconds into it. I would normally
attribute something like this to simple bad web programming, but given A. The
fact that the webpage loads properly, and B.This problem also happened on this
very bugzilla report form to me earlier today (though I can't be sure if it's
from the same cause, because the bugzilla problem only happened once, while the
Xanga one was consistent). I believe it has a direct connection with embedded
music files on Xanga, though I can't be entirely sure. Additionally, I noticed
when I went to the comments pages on many of these Xangas, the comments box
would shift over to the right side of the screen, and stay there, allowing me to
type in the box but not to click on the submit button. My text would continue
off of the page as well, so I had no idea what I was typing for sure. I KNOW
it's not a Gecko problem, as Firefox on PC works just fine with it (the Mac
version has problems, though) and I know it is not a problem with ALL Macs, as
Omniweb and iCab have no problems. 

Reproducible: Always

Steps to Reproduce:
1.Go to the site.
2.Wait for the song to load, and sometimes play for 10-30 seconds or so.
3.Scroll.

Actual Results:  
The pages 'wiped themselves out.' They just turned white. When I went to another
tab and came back, the pages looked fine again, but when I tried to scroll, they
would white out again. Interestingly enough, though, sometimes certain
background images would stay while the rest of the site's content would vanish.

Expected Results:  
Not only properly render the pages, but allow them to continue working fine.
(Reporter)

Comment 1

14 years ago
Another couple examples of Xangas this occurs on: 
http://www.xanga.com/home.aspx?user=CityLove_787
http://www.xanga.com/home.aspx?user=Braveshalo10

Comment 2

14 years ago
> Firefox on PC works just fine with it (the Mac version has problems, though)

So Firefox on Mac has the same problem?
these all work fine for me with 082.

does firefox have the same problem?
These also work fine for me with the 02/27 nightly (haven't upgraded yet).

Are you using a nightly? If so, which one?
All working fine for me with the latest nightly, too.
(Reporter)

Comment 6

14 years ago
It occured for me on Firefox last I checked. I do know that this has been a
recent  regression in Camino. At least a fairly recent one. I went back to the
January 31st nightly and it works brilliantly. I'll be staying there for awhile,
I suppose.

Comment 7

14 years ago
Both sites work and scroll fine in the 3/21 nightly.
(Reporter)

Comment 8

14 years ago
Well, I've upgraded once again to the latest nightly and it still will load sites properly, and then will stop 
working after a little while (generally some time after songs have loaded in the background, so I'm 
guessing it's a direct connection to this specific plugin.) Additionally, I've noticed that the websites 
work fine in Webkit browsers, but the songs don't load. 
Do you have the WMP (Windows Media) plugin installed?
(Reporter)

Comment 10

14 years ago
Yes. That was not the problem. Installing WMP simply allows Webkit-based
browsers to play the sound and video. Camino, being Gecko, could already do
that, and having the plugin installed did not affect it. I've had other people
confirm this issue with me on the forums. This is definitely a real Mac Gecko
browser issue. I cannot think of any other possible explanation. The website AND
the embedded file render perfectly, and the sound plays fine. It's not until a
few seconds later that the site erases itself when scrolling, usually. I've
changed the main instance URL. That's where I'm finding the problem now. The
main site previously listed is outdated.
I *do not* have WMP installed, and the page loads/scrolls without any erasing
for me, 20050327 0.8+  (The song on the page is an .asf file, which will not
play without WMP)

What version of Camino are you using?

I do think this is a duplicate of bug 272699, though.
(Reporter)

Comment 12

14 years ago

*** This bug has been marked as a duplicate of 272699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

14 years ago
Thanks. Now I'll have a confirmed one to watch.
You need to log in before you can comment on or make changes to this bug.