If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

user can not override plugins, i.e. force use of an external instead of an internal helper application

RESOLVED DUPLICATE of bug 19118

Status

SeaMonkey
Preferences
RESOLVED DUPLICATE of bug 19118
13 years ago
13 years ago

People

(Reporter: Sven Utcke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

In my environment, all users have

kogspc2>/home/utcke% echo $MOZ_PLUGIN_PATH 
/software/acrobat-5.0.7/Browsers/intellinux:/software/flash-7/Linux/plugins:/software/j2sdk1.4.2_04/Linux/jre/plugin/i386/ns610-gcc32

which, among other things, enables the acrobat-plugin.  However, I prefer to
read pdf's in a seperate acrobat (for several reasons, most noteably that the
keybindings inside the acrobat plugin interfer with my window-manager, and that
the plugin is for some reason dead-slow).  Ok, I realise I _could_ simply edit
MOZ_PLUGIN_PATH, but I don't think I should need to.  Instead the following
_should_ work:

Edit -> Preferences... -> Navigator - Helper Applications

choose application/pdf

Edit...
Open it with: acroread
OK

But now mozilla tells me:

  Mozilla can handle this type internally.  For such types, a Helper Application
  will only be invoked if the server requests external handling.

Excuse me?  I don't give a flying f*ck what the server requests, I, The User,
just requested external handling, and no matter how proud mozilla is that it can
now use plugins, I at least expect a button / checkbox / whatever which allows
me to override this.  Well, not so...



Reproducible: Always

Steps to Reproduce:
1.Edit -> Preferences... -> Navigator - Helper Applications
2.choose application/pdf
3.Edit... Open it with: acroread OK

Actual Results:  
mozilla tells me:

  Mozilla can handle this type internally.  For such types, a Helper Application
  will only be invoked if the server requests external handling.

Expected Results:  
Simply do what I asked it to do: Use the external application I entered!

Comment 1

13 years ago
This is covered by bug 19118.

*** This bug has been marked as a duplicate of 19118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.