quickly disable all extensions without entering safe mode

RESOLVED FIXED

Status

()

--
enhancement
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: lindyboi, Assigned: bugs)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sub-bug of 265154)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

When debugging a problem, it would be helpfulto quickly disable all extensions,
and then re-enable them one by one. Currently, the only options are safe mode
(which leaves all extensions disabled) or disabling one by one by hand.

Context menu option to "Disable All" from the Extensions window would be helpful.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1
> 
> When debugging a problem, it would be helpfulto quickly disable all extensions,
> and then re-enable them one by one. Currently, the only options are safe mode
> (which leaves all extensions disabled) or disabling one by one by hand.
> 
> Context menu option to "Disable All" from the Extensions window would be helpful.
> 
> Reproducible: Always
> 
> Steps to Reproduce:

This is a great idea and would greatly help me track down bugs.

I'm all for something like this.  How feasable is it though?
--Chris

Comment 2

14 years ago
-> Extension Manager
Component: Download Manager → Extension/Theme Manager
QA Contact: aebrahim-bmo → bugs
(Reporter)

Comment 3

14 years ago
Great, I dup-ed myself. Should I stop gerunding in my bug names?

I'm going to put this as blocker on my other bug, although I woudl like to point
out that "enable all" is a far less interesting case than "disable all" if one
of these does end up getting merged to the other.

Rephrasing slightly
Blocks: 265154
Summary: Command to disable all extensions → quickly disable all extensions without entering safe mode

Comment 4

14 years ago
I don't see how it is different from bug 265154, but not I'm not marking this a
dupe of that since you seem to think otherwise. Confirming instead, since
there's no point in keeping this unco.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Whiteboard: sub-bug of 265154
Version: unspecified → Trunk

Comment 5

13 years ago
Fixed by bug 304403.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.