page scroll gets stuck (grows feelings of hope)

VERIFIED DUPLICATE of bug 48037

Status

()

--
minor
VERIFIED DUPLICATE of bug 48037
14 years ago
14 years ago

People

(Reporter: paul.stanton, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

well, i started looking for a duplicate of this bug but after reading about 3 i
decided no one would be 1. bored enough or 2. anal enough to figure out the
exact sequence of events that reproduce this bug, and if they did bother to log
it as it's pretty goddamn trivial anyway. but this is Friday so here we go:

i can make a scroll bar have feelings.

please follow the steps to reproduce and be very careful to follow them exactly.

Reproducible: Always

Steps to Reproduce:
0. make sure your window is not 'maximised'
1. open a page that requires you to scroll vertically (such as this one ;))
2. click and hold your left mouse button on the vertical scroll control dragging
it up and down
3. while still holding the left mouse button move your mouse just right of the
scroll control, onto the application border so to speak, right click and release
both mouse buttons
Actual Results:  
now your free to move your cursor around and the scroll control will follow,
almost in yearning for you to return and caress it more. if you click your mouse
buttons it will lose hope and return to sitting there motionless.

Expected Results:  
a scroll control doesn't have feelings and therefore no hope. it should only
move when i play with it.

i expect this bug to stay in this bug tracking system for a long, long time. who
would bother to fix it? it is born to a long and prosperous life. please treat
it with respect. oh, and my spelling is good.

Comment 1

14 years ago
This bug probably belongs in Core - XPToolkit/Widgets.

I can reproduce on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223
Firefox/1.0.1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316
Firefox/1.0+

Comment 2

14 years ago
unfortunately, quite a few people have reported this.  apparently we have no
lives.  :(

dupe of "Scrollbar sometimes follows mouse movement even with no buttons pressed"

*** This bug has been marked as a duplicate of 48037 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.