deleting or detaching attachment from IMAP message duplicates the message temporarily

VERIFIED FIXED in Thunderbird2.0

Status

defect
VERIFIED FIXED
14 years ago
9 years ago

People

(Reporter: bugzilla, Assigned: Bienvenu)

Tracking

({verified1.8.1})

Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
found using 20050315-trunk tbird builds on linux fc3 and mac os x 10.3.8.

setup: have a POP account with messages containing attachments. in my scenario,
I keep the messages stored on the server.

1. select a message containing attachments (message pane in 3pane or standalone
window).

2. in the attachment pane, right-click/bring up the context menu and select any
of the following:

Delete
Detach
Delete All
Detach All

3. if prompted for a location (ie, for detaching), chose the location in the
resulting file picker. otherwise, when being prompted that the attachment will
be removed, hit OK to proceed.

4. watch the thread pane in the 3pane window.

results: another (unread) copy of the message appears in the thread pane, which
shows that the attachments have been removed. the original message (still with
attachments) is still listed in the thread pane.

this isn't a problem on IMAP, where the message on IMAP is reloaded as unread,
but with the correct (new) attachment state.
(Assignee)

Comment 1

14 years ago
Posted patch proposed fix (obsolete) — Splinter Review
using the copy service will cause us to get the copy done notification.
Attachment #177800 - Flags: superreview?(mscott)

Comment 2

14 years ago
Comment on attachment 177800 [details] [diff] [review]
proposed fix

although currently you might get told the copy is done twice :)
Attachment #177800 - Flags: superreview?(mscott) → superreview+
(Reporter)

Comment 3

14 years ago
I know this hasn't been checked in yet, but using 20050324-trunk bits I'm now
seeing this duplication with IMAP messages. funky.

Comment 4

14 years ago
*** Bug 287938 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

14 years ago
this patch will fix it for pop3. It doesn't quite fix it for IMAP - the original
message is deleted, but you can't see that until the folder is refreshed, for
some reason.
(Assignee)

Comment 6

14 years ago
Posted patch proposed fixSplinter Review
fix imap and pop3 cases. IMAP and POP3 are sufficiently different in
notifications that we need to handle things in ::OnStopRunningUrl and
::OnStopCopy in specific ways.
Attachment #177800 - Attachment is obsolete: true
Attachment #179200 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #179200 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

14 years ago
reopening - just shoot me now, this is still broken for imap, when I run w/o my
breakpoints :-(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: deleting or detaching attachment from POP message duplicates the message → deleting or detaching attachment from POP+IMAP message duplicates the message

Comment 8

14 years ago
David, has your proposed fix been checked in? Because I never saw trunk TB
working flawlessly with pop3. Delete works in most cases. Dettach acts usually
mangles attachments and, in some cases, it duplicates them. Currently using
20050716 on Windows.
(Assignee)

Comment 9

14 years ago
yes, this fix was checked in. But it only had to do with deleting the old
message, not to do with the stripping of the attachment. If you have a message
for which detaching doesn't produce a correctly formatted message, could you
send me a copy of the message, or post it here?

Comment 10

14 years ago
*** Bug 308137 has been marked as a duplicate of this bug. ***
*** Bug 310256 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
This is still a problem for me using IMAP with 1.5 RC1.

Comment 13

14 years ago
Me too...
This is still a problem for me using IMAP with 1.5 RC1.
I'm running Windoze XP Pro SP2.
*** Bug 325097 has been marked as a duplicate of this bug. ***
*** Bug 310177 has been marked as a duplicate of this bug. ***
If you have a message with more then one attachment and you are deleting all attachments step by step, then only the last two messages are visible. No more duplicated will be created.

1. Delete first attachment => Duplicate message appears
2. Delete second attachment => Duplicated message is duplicated and original message is deleted

Happens with Thunderbird 1.5 Linux and Courier IMAP.

Comment 17

13 years ago
I'm not sure if this is the same issue, but the following test case also leads to duplicate messages

1) In the account preferences set "To save disk space, do not download  Messages larger than xx kB" to for instance x= 500kB
2) receive a message that's larger than 500kb. 
3) in the message pane, click on the link to download the rest of the truncated message.

The result is that the message is shown twice in the Inbox, with equal sizes. One message stil shows the "truncated" message, while the second one is the completely downloaded message.

version 3 alpha 1 (20060414), OS X
(Assignee)

Comment 18

13 years ago
I believe that's a different issue, and is a relatively recent regression on both the trunk and 1.8 branches.

Comment 19

13 years ago
putting this in the 2.0 bucket so we don't lose track of it. I can still reproduce the message duplication issue for IMAP per comment 7.
Flags: blocking-thunderbird2+
Target Milestone: --- → Thunderbird2.0
(Assignee)

Comment 20

13 years ago
changing summary to reflect remaining bug - imap only, and the duplication is temporary.
Status: REOPENED → ASSIGNED
Summary: deleting or detaching attachment from POP+IMAP message duplicates the message → deleting or detaching attachment from IMAP message duplicates the message temporarily
*** Bug 327051 has been marked as a duplicate of this bug. ***
*** Bug 320461 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
Version: 2006-10-31-05-mozilla1.8.0
OS: Windows XP SP2

I'm using IMAP.
If i forward message with attachments using "inline" method, i got attachments dublicated and always one of them is corrupted.
(Assignee)

Comment 24

13 years ago
Posted patch proposed fixSplinter Review
sigh, these are imap-message uri's, not imap: uri's...
Attachment #244496 - Flags: superreview?(mscott)

Comment 25

13 years ago
Comment on attachment 244496 [details] [diff] [review]
proposed fix

:)
Attachment #244496 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 26

13 years ago
fixed on trunk and branch. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Verified with version 3 alpha 1 (20061119) and version 2 beta 1 (20061116)
Status: RESOLVED → VERIFIED

Updated

13 years ago
Depends on: 360342
Duplicate of this bug: 366428
You need to log in before you can comment on or make changes to this bug.