download progress bar does not respect graphite system setting

RESOLVED INVALID

Status

Camino Graveyard
OS Integration
--
trivial
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Allan, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050309 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050309 Camino/0.8+

When the system is set to a Graphite appearance, most widgets change. But the
progress bar in the download manager.

Reproducible: Always

Steps to Reproduce:
1. Set appearance to Graphite in System Preferences > Appearance
2. Download something
3. L@@K

Actual Results:  
A little blue progress bar appeared

Expected Results:  
A little grey progress bar should have appeared.
(Reporter)

Comment 1

14 years ago
Ooh, that goes for the page-loading progress bar too.
(Assignee)

Comment 2

14 years ago
i'm not even sure how to fix this. it's a native progress meter. if it doesn't
change, there's not much we can do about it.

Comment 3

14 years ago
Reproduced with 2005032508 on 10.3.8

Comment 4

14 years ago
Could _NOT_ reproduce with nightly builds:

- 2005032108 (v0.8+)
- 2005032908 (v0.8+)

both on 10.3.8, all updates installed.

Comment 5

14 years ago
Huh; they've always been Graphite for me (I use the Graphite appearance, too).
(Reporter)

Comment 6

14 years ago
Yep, still broken here. It's way less than I thought though: It turns out they
don't change colour when the preference is changed - which they technically
should - but they do after a relaunch. Thanks.
I just checked (switched theme *while* apps were open, then quit and relaunched)
and progress bars in other apps don't change without a relaunch of the app,
either, so if this is a bug, it's Apple's.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.