Last Comment Bug 286682 - [ne] Nepali: Firefox Localization
: [ne] Nepali: Firefox Localization
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
: 279244 331845 (view as bug list)
Depends on:
Blocks: 391510
  Show dependency treegraph
 
Reported: 2005-03-17 20:39 PST by CK Raut
Modified: 2012-05-24 20:52 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Localize Files for ne-NP locale (288.55 KB, application/x-zip-compressed)
2005-08-11 05:27 PDT, CK Raut
no flags Details
DSA Public Key (612 bytes, text/plain)
2005-08-11 05:28 PDT, CK Raut
no flags Details
Firefox 2.0.0.4 translation for Nepali (ne-NP) (203.04 KB, application/x-gzip)
2007-08-08 06:13 PDT, Basanta Shrestha
l10n: review+
Details

Description CK Raut 2005-03-17 20:39:05 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9 (ax)

This is mozilla localization for Nepali language.

Reproducible: Always
Comment 1 CK Raut 2005-03-17 20:42:30 PST
Code: ne-NP
Email: meetquant@yahoo.com
Name: CK Raut
Comment 2 Robert Kaiser 2005-03-18 05:18:01 PST
What product? Firefox? Thunderbird? Mozilla suite?
Comment 3 CK Raut 2005-03-18 18:41:36 PST
Product: Mozilla Firefox
Country Code: ne-NP
Email: meetquant@yahoo.com
Name: CK Raut
Comment 4 Axel Hecht 2005-06-30 02:52:42 PDT
CK, there is another registration for nepali, bug 279244. Do you want to join
forces with them?

Neither of you has submitted code yet, I suggest that you focus on 1.1 now.
Comment 5 CK Raut 2005-08-04 12:11:04 PDT
(In reply to comment #4)
> CK, there is another registration for nepali, bug 279244. Do you want to join
> forces with them?
> 
> Neither of you has submitted code yet, I suggest that you focus on 1.1 now.

I've finished translation and correction for Mozilla Firefox 1.0.6, but packing
it seems confusing (there are lots of information for different version
available on the site). Can you help me to pack it into .xpi? [or point to
specific note valid for 1.0.6] . As mozilla site says: full build is
(encouraged) to be done by mozilla.org, would you please help me in this regard
as well? I'm not given CVS access, please voucher me so that I can upgrade this
localization to latest builds.

SO excited to see it in Nepali. (its already 4am here! see u tommorrow)
Comment 6 CK Raut 2005-08-11 05:27:31 PDT
Created attachment 192360 [details]
Localize Files for ne-NP locale
Comment 7 CK Raut 2005-08-11 05:28:51 PDT
Created attachment 192361 [details]
DSA Public Key
Comment 8 CK Raut 2005-08-11 05:31:47 PDT
I'm sending the localized files, and a public key; required for the CVS Write
access, and tommorrow I'll send fax of the Contribution Form.
Comment 9 CK Raut 2005-08-11 23:36:02 PDT
The contribution form was faxed. Please update the bug to confirm the receipt.
ALso, the Nepali Localization ne-NP has been already made available (currently) at:
http://www.ecubers.com.np/mozilla
(as language pack .xpi file, and win32 installer )

If CVS write access permission is going to take some time, it'll be effective if
someone (possibly MLP staffs) help to put them at mozilla.org ftps.
Comment 10 Axel Hecht 2005-08-15 05:17:10 PDT
Comment on attachment 192360 [details]
Localize Files for ne-NP locale

We need a source localization for review. I suggest going for the trunk, or the
1.8 branch (MOZILLA_1_8_BRANCH) now.

Be sure to read http://wiki.mozilla.org/L10n:Firefox_Extras, too.
Comment 11 Axel Hecht 2005-08-15 05:20:46 PDT
*** Bug 279244 has been marked as a duplicate of this bug. ***
Comment 12 Axel Hecht [:Pike] 2006-03-29 06:33:47 PST
*** Bug 331845 has been marked as a duplicate of this bug. ***
Comment 13 Axel Hecht [:Pike] 2006-03-29 06:36:59 PST
http://wiki.mozilla.org/Draft:L10n:Creating_a_new_Localization is the best thing
we currently have in terms of docs for new locales.

What we need right now is a source localization for 1.5.0.x, or for 2.0, though
that is a very moving target right now, so I can't really review it thoroughly.

I would like to see some joining of forces, too, that can only help us.
Comment 14 Basanta Shrestha 2007-07-18 05:27:04 PDT
I am planning on translating firefox 2.0.0.x soon. Has any one already started? 

I have also registered ne-NP team in http://wiki.mozilla.org/L10n:Teams:ne-NP. Wiki can be edited if you want to add as potential peer. 

Comment 15 Basanta Shrestha 2007-08-08 06:13:24 PDT
Created attachment 275767 [details]
Firefox 2.0.0.4 translation for Nepali (ne-NP) 

Firefox Translation for version 2.0.0.4 has been attached by 
Basanta K. Shrestha, 
basanta@mpp.org.np
basanta.shrestha@gmail.com
Madan Puraskar Pustakalaya
Comment 16 Axel Hecht [:Pike] 2007-08-09 04:15:10 PDT
Comment on attachment 275767 [details]
Firefox 2.0.0.4 translation for Nepali (ne-NP) 

This is looking good, let's proceed.

Technical review nits:

toolkit/chrome/global/intl.properties#intl.accept_languages could probably mention English, too?

browser/profiles/bookmarks.html is completely busted, but I can fix that in the initial landing (I usually do that).

We'll need to figure out search and stuff in a separate bug.

Basanta, do you already have a cvs account request bug filed? If not, please file one, depending on this bug, following the instructions at http://developer.mozilla.org/en/docs/Create_a_new_localization#File_CVS_account_bug
Comment 17 Axel Hecht [:Pike] 2007-08-23 16:22:27 PDT
I have just sent the account request over to server-ops, if you don't mind, I'll do the initial check-in. There are more ways to break that than after that.
Comment 18 Axel Hecht [:Pike] 2007-08-23 17:41:13 PDT
Basanta, could you strip down the page on http://wiki.mozilla.org/L10n:Teams:ne-NP a bit to be closer to what, say, http://wiki.mozilla.org/L10n:Teams:de does? Feel free to add a link to, say, http://wiki.mozilla.org/L10n:Teams:ne-NP:Details to it, that holds all the general information. For the core page, we care more about the direct context person and peers for the applications and toolkit.
Comment 19 Axel Hecht [:Pike] 2007-08-23 18:34:32 PDT
Landing bug 393485 filed, initial landing done. I'll leave this bug open just for the actual exposure on wiki.m.o, for which a more compact information on the team page is better, see comment 18.
Comment 20 Gervase Markham [:gerv] 2007-09-19 02:16:34 PDT
Basanta: could you please clean up your l10n team page, as Axel has requested?

Thanks :-)

Gerv
Comment 21 Axel Hecht [:Pike] 2007-10-05 03:24:53 PDT
Fixed, thanks. The rest of the game is in the hands of bug 397635.

Note You need to log in before you can comment on or make changes to this bug.