a popup opened from inside a popup freezes

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xul frame construction])

Attachments

(1 attachment)

660 bytes, application/vnd.mozilla.xul+xml
Details
When using a <button popup="foo"> inside a popup, mozilla freezes when opening
that subpopup. The popup still reacts though.

It might not be legal, dunno. But it shouldn't freeze.

(i can't give exact details, since i'm not on windows)
(Reporter)

Comment 1

13 years ago
Created attachment 177883 [details]
testcase

tsteps to reproduce: click the button, click 'click', freeze.
(Reporter)

Updated

13 years ago
Blocks: 286747

Comment 2

13 years ago
The problem isn't during the "popup" the problem is when the second popup window
closes. So the sequence is click the button. click "click". click "close2" (or
click away so that the second popup closes) - Freeze.

-Andrew
Whiteboard: [xul frame construction]

Comment 3

13 years ago
nominate blocking1.8.1
Flags: blocking1.8.1?

Comment 4

12 years ago
Not going to block 1.8.1 for this bug, but we'll happily consider a baked-on-trunk patch.
Flags: blocking1.8.1? → blocking1.8.1-

Comment 5

12 years ago
When you say 'freeze', do you mean the browser hangs, or just that the menu doesn't close properly?

Comment 6

12 years ago
The browser is still functional, but the original/parent popup menu is displayed even when it should be hidden (minimizing the browser won't even hide it) and no longer responds to clicking of any kind. This is still an issue on 1.5.0.4 on windows xp. I hope that's clearer. If you need me to check anything, just let me know. Thanks!
-Andrew

Comment 7

12 years ago
This will be fixed by 279703
Depends on: 279703

Comment 8

11 years ago
Should now be fixed with bug 279703.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.