link error, Undefined symbol, in libmozbrwsr.so on AIX-4.3.2

VERIFIED DUPLICATE of bug 28114

Status

SeaMonkey
Build Config
P3
normal
VERIFIED DUPLICATE of bug 28114
18 years ago
13 years ago

People

(Reporter: Ciaran Deignan, Assigned: Jim Dunn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using the nightly build from 20/2/00, the build fails when linking 
libmozbrwsr.so with the following command:
/usr/ibmcxx/bin/makeC++SharedLib_r -ldl -p1 -brtl -bso -o libmozbrwsr.so    
nsBrowserInstance.o   -L../../../dist/bin -L../../../dist/lib -lxpcom -lmozjs 
-lplds3 -lplc3 -lnspr3 -lpthread   -lnsl -lC -ldl -lm -lc_r

The error reported is:
ld: 0711-317 ERROR: Undefined symbol: .NS_NewTimer(nsITimer**)

Using the -bnoquiet option manually the following detailed information is 
provided:
ld: 0711-318 ERROR: Undefined symbols were found.
        The following symbols are in error:
 Symbol                    Inpndx  TY CL Source-File(Object-File) OR Import-File
{Shared-object}
                              RLD: Address  Section  Rld-type Referencing Symbol
--------------------------------------------------------------------------------
--------------
ld: 0711-317 ERROR: Undefined symbol: .NS_NewTimer(nsITimer**)
 .NS_NewTimer(nsITimer**) [13339] ER PR nsBrowserInstance.cpp(nsBrowserInstance
.o)
                                   000197ac .text    R_RBR    [10366] <.PageCycl
er::StartTimer()>
ER: The return code is 8.

I presume that there is a lib missing, but NS_NewTimer appears to be defined
in several files...

Thanks
Ciaran
(Reporter)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 28114 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.