message labeled as Cp1252 doen't show beyond norwegian character

VERIFIED FIXED in M15

Status

MailNews Core
MIME
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: tv, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch available)

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
An Imap message (encoded in standard text/plain, quoted printable), doesn't
display beyond a norwegian "ae" character.
(Reporter)

Comment 1

19 years ago
Created attachment 5546 [details]
source of email that shows the bug.

Comment 2

19 years ago
cc: kat

Comment 3

19 years ago
The probelm seems to be that we don't recognizet
the charset alias "Cp1252" which is in this message.
I tried "CP-1252" and that did not work, either.
"Windows-1252" does work, however.

We probably should enrich our charset alias table.
CC'ing nhotta and ftang. This probably should go to 
ftang. Intially sending it to nhotta.
Assignee: rhp → nhotta

Comment 4

19 years ago
Assigning myself as QA contact.
QA Contact: lchiang → momoi

Comment 5

19 years ago
Confirming the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

19 years ago
8-bit characters are represented in QP in this msg.
I thought we are defaulting to ISO-8859-1 in this 
kind of case when we don't recognize the charset name.
In future, when the message viewing default and charset
menu setting are working, we should be able to avoid this
type of problem.
(Assignee)

Comment 7

19 years ago
Accepting the bug, changed the summary.
This can be fixed by adding error handling code in case the alias resolution 
fails.
charsetalias.properties contains alias lists, if we want to change it, reassign 
to ftang.
Status: NEW → ASSIGNED
Summary: imap message doen't show beyond norwegian character → message labeled as Cp1252 doen't show beyond norwegian character
(Assignee)

Comment 8

19 years ago
Created attachment 5565 [details] [diff] [review]
a patch file
(Assignee)

Comment 9

19 years ago
Created attachment 5566 [details] [diff] [review]
a patch (ignore the last one)
(Assignee)

Updated

19 years ago
Whiteboard: patch available
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 10

19 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
** Checked with 6/5/2000 Win32 build **

This has been workign for some time.
With the above build, I can see the test message by 
tv in Norwegian and also other Windows-1252 msgs even when
they are labeled as CP1252.
Marking verified as fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.