All users were logged out of Bugzilla on October 13th, 2018

a half of links on a page nor highlighted neither could be used to navigate

RESOLVED DUPLICATE of bug 102695

Status

()

--
major
RESOLVED DUPLICATE of bug 102695
14 years ago
14 years ago

People

(Reporter: zya, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the page at http://www.search-lan-share.com/lionel-726.html , there are 27
links on eBay auctions. First 13 of them shows up just like a regular text, not
like links, the rest 14 looks and works as it should be. Other browsers display
it correctly.

Reproducible: Always

Steps to Reproduce:
1. Open the page http://www.search-lan-share.com/lionel-726.html
2. Take a look at the problem
3. Think, think, think, think, transfer to a developer

Actual Results:  
a page loaded, but first 13 links on eBay auctions are not browseable

Expected Results:  
links have to work as links

Comment 1

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

Your problem is similar (and may be identical) to Bug 286314 "links appear blue,
but are not clickable (although the page html/css validates OK)"

The visible manifestation is due to the div#tre2 extending over the upper half 
of the block with the links, and masking them, so that they never receive mouse
clicks.

There are several things you could do to mitigate this, use a button rather than 
a div for your interface, make the divs not overlap, or make the content a 
child.

I can't say whether this (or for that matter Bug 286314) indicates a defect
in Firefox, though Bug 286314 comment 2 gives a pointer away from that 
conclusion. It is a remote possiblity that Firefox is either not noticing 
the z-order, or not observing it.

Are you in a position to check whether Konqueror/safari and Opera also render 
this the way that Gecko does?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.