Closed Bug 286871 Opened 17 years ago Closed 15 years ago

TB includes Xpfe contentAreaUtils.js instead of Browser one.

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 333607

People

(Reporter: sgautherie, Assigned: mscott)

References

Details

[Mozilla Thunderbird, version 1.0+ (20050319)] (nightly) (W98SE)

Trunk error, not present in v1.0 branch !!?
{{
Error: redeclaration of const SAVETYPE_COMPLETE_PAGE
Source File: chrome://communicator/content/contentAreaUtils.js
Line: 245
}}
_when starting TB_.

<http://lxr.mozilla.org/mozilla/search?string=SAVETYPE_COMPLETE_PAGE>
{{
SAVETYPE_COMPLETE_PAGE
/xpfe/communicator/resources/content/contentAreaUtils.js, line 245 -- const
SAVETYPE_COMPLETE_PAGE = 0x00;
/xpfe/communicator/resources/content/contentAreaUtils.js, line 275 -- var
saveAsType = SAVETYPE_COMPLETE_PAGE;
/xpfe/communicator/resources/content/contentAreaUtils.js, line 310 -- // If we
should save as a complete page, the saveAsType is SAVETYPE_COMPLETE_PAGE.
/xpfe/communicator/resources/content/contentAreaUtils.js, line 313 --
(((saveMode & SAVEMODE_COMPLETE_DOM) && (saveAsType == SAVETYPE_COMPLETE_PAGE)) ||
}}
It would seem that this file is loaded more than 1 time at/from a given place...

But the cause rather seems to be
<http://lxr.mozilla.org/mozilla/find?string=contentAreaUtils.js>
{{
/browser/base/content/contentAreaUtils.js
/xpfe/communicator/resources/content/contentAreaUtils.js
}}

This may be 2 issues in 1...
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333607
Status: RESOLVED → VERIFIED
V.Duplicate, as reporter.
Component: Build Config → Mail Window Front End
OS: Windows 98 → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.