CSS text-decoration inconsistent display

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
trivial
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: R. A. Stern, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

The use of the text-decoration formatting CSS tag fails in files with a large
number of elements using the same style. When using a single .class:hover {}
style for a large (40+) list of anchor elements, some elements do not perform
the :hover style text-decoration (in this case underline) as described by the
CSS file. Most elements perform the styling correctly. I've only noticed this
when using the underline property in conjunction with text-decoration in :hover.

Reproducible: Sometimes

Steps to Reproduce:
1. There are no special browser configurations or setup, the error occurs in
pages with large numbers of :hover styles of CSS classes.

Actual Results:  
Some elements do not correctly display the prescribed style.

Expected Results:  
All elements assigned the class should react the same.

Comment 1

13 years ago
Please provide a url or even better, attach a testcase to this bug showing the
issue:
https://bugzilla.mozilla.org/attachment.cgi?bugid=286887&action=enter
Assignee: firefox → dbaron
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

13 years ago
http://gizmos.aodojo.com/beta/charbuild.php?mode=php&pane=abil&race=fey&c1=wiz&c2=barb&c3=rogue&c4=sha

Page content is dynamically generated however stylesheets are static.

Comment 3

13 years ago
The testcase is broken: the anchors are missing in the source, if you mean
everything starting with "throwing".


(Reporter)

Comment 4

13 years ago
No the problem is not in reference to those without an anchor, actually it
starts with "axe"

I found the following elements to not show the :hover

"axe"
"abjure"
"animate dead"
"bless"
"momentary darkness"

All elements listed above have anchors.

Some cases are missing anchors, which is deliberate. "throwing" for example,
does not have a help reference and thus should NOT have an anchor, if it did it
would be incorrect. The problem is with cases, as mentioned above, which have
anchors and seem to not display the :hover correctly.
Worksforme, Linux trunk.
Assignee: dbaron → nobody
Component: Style System (CSS) → Layout: Fonts and Text
QA Contact: ian → layout.fonts-and-text
(Reporter)

Comment 6

13 years ago
Possibly of note:

When I save a copy of the source upon my local drive, and view it from local
disk everything renders correctly. I've viewed the file remotely on serveral
machines  (Win2k, XP home & pro), all render fine. When I view the page remotely
from 'this' machine which I reported the problem with, I get the same results
with those elements listed in note #4. When I view the page remotely using an
alternate browser from this machine, it renders correctly. I can isolate it to
only when I view the page from its remote source from 'this' machine using FireFox.
Component: Layout: Fonts and Text → Style System (CSS)
Component: Style System (CSS) → Layout: Fonts and Text
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 8

9 years ago
I remember that there had been such problems up to Gecko 1.8, but they were all fixed in 1.8.1 and higher.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.