"border-collapse: collapse" of a table inside div causes table border rendered incorrectly

RESOLVED DUPLICATE of bug 155955

Status

()

RESOLVED DUPLICATE of bug 155955
14 years ago
14 years ago

People

(Reporter: support, Unassigned)

Tracking

1.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

The table inside the div is rendered so that its top border is not visible in
the viewport. Increasing table's margin shifts it down and restores the border
(as expected). Finally, changing border-collapse to "separate" does not exhibit
the same problem. It appears that FF ignores "border-collapse: separate" when
trying to collapse adjoining margins in this case.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

<html>
<head><title>border-collapse: collapse bug in FF</title></head>

<body style="background-color: #ACF;  padding: 0; margin: 0;">

<div style="background-color: white; margin: 0; padding: 0;">
	<table style="border-collapse: collapse; margin: 0 auto; border: 1px solid blue;">
		<tr><td>table</td></tr>
	</table>
</div>

</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Save provided HTML as file and view it in FF v1.0.1

Actual Results:  
The top margin of the table is not visible

Expected Results:  
It should be visible

Opera and IE render this HTML correctly.

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
that happens only in strict mode

*** This bug has been marked as a duplicate of 155955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.