Signature with images doesnt attach images in a certain configuration

RESOLVED DUPLICATE of bug 270380

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 270380
13 years ago
13 years ago

People

(Reporter: Ambarish Chaudhari, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

If you make an email signature with images, the images are not attached if you
choose to start reply above the quote and place signature below your reply
(above the quote)

Reproducible: Always

Steps to Reproduce:
1. Go to Tools->Accounts->Composition & Addressing
2. Check "Compose messages in HTML format"
3. Check "Automatically quote the original messagin while replying"
3. Select "start my reply above the quote"
4. Select "place my below your reply (above the quote)"
6. Create a signature that contains images (which is a bit of a work around at
this stage!)
5. Reply to a mail and send it.
6. Check in "Sent" folder.
Actual Results:  
Images show up in the compose window but are not attached in the sent message.

But image are attached if you send a new message OR change the above config to
"place my signature below the quote (recommended)"

Expected Results:  
Images should be attached and the recommendation to place signature below the
quote should go away :-)

This is normal Outlook behaviour. So, fixing this won't frustrate the
"switching" audience and make them turn back to Outlook.

Also, in a replied email, recipients usually concentrate on the top of the mail
to see what the reply is. So, choosing to place reply above quoted original
message is a very common practice.

And having a signature way below the actual reply is not cool! 

I guess the issue is originating from the fact that signature is starting with
"--" and needs to be placed it with a lighter text-color (or handle it in
another way)

So there may be a technical aspect to it, but I think fixing this can support a
very normal user behavior.

FYI, I have tried to fix it by simply copying the signature and pasting it in
the same place, to fool the client that it is some other data pasted by user.
But, Thunderbird seems to be unexpectedly smart there :-) and the work around
doesn't quite help.

Comment 1

13 years ago
(In reply to comment #0)
> Images should be attached and the recommendation to place signature below the
> quote should go away :-)

This is the losing side of an argument that was settled years ago.  The 
recommendation will stand.  If you prefer the behavior of a different mail 
client, you are advised to use that client.

*** This bug has been marked as a duplicate of 270380 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > Images should be attached and the recommendation to place signature below the
> > quote should go away :-)
> 
> This is the losing side of an argument that was settled years ago.  The 
> recommendation will stand.  If you prefer the behavior of a different mail 
> client, you are advised to use that client.

OK. May I please have a pointer to that argument if it's online? I wasn't aware
of it. Well, it's fine if it is on the lines of what I thought it is:
-------
>> I guess the issue is originating from the fact that signature is starting
>> with
>> "--" and needs to be placed it with a lighter text-color (or handle it in
>> another way)
--------
Or was it more religious than that?

About using another client: No, I don't prefer the 999 other aspects of the
"other client". But, I would like to see more people move from that to Tb. And
those who make the switch a little later (like me) feel the pinch more than
those who have been around in the Mozilla world. So I thought it may be good to
raise it. Coz, I fear some even may get discouraged about the switch with such
simple things thinking "may be it's not there yet."

In this example, the feature works 99% in Tb, but we are talking about the last
1% that isn't, as it should by definition.

So please dont advise me to switch back to the "other thing" just for this. :-( 
I would rather live with this till it gets fixed.

PS: Did I send this on a Monday morning? Sorry!

> 
> *** This bug has been marked as a duplicate of 270380 ***
You need to log in before you can comment on or make changes to this bug.