No way to log into bugzilla from index.html

VERIFIED DUPLICATE of bug 15967

Status

()

Bugzilla
Bugzilla-General
P3
enhancement
VERIFIED DUPLICATE of bug 15967
18 years ago
5 years ago

People

(Reporter: Colin Slater, Assigned: justdave)

Tracking

Details

(Reporter)

Description

18 years ago
THere is no easy way to login to bugzilla without entering/changing a bug. This 
makes it so that you can't get your saved querys immediatly.

Comment 1

18 years ago
What's so hard about the "Log in" link that appears at the bottom of every page
(except the toplevel index.html page)?  Note that if you're already logged in,
this link appears as "Log out".
Well, you could always put the "log in" link on the front page, just above
"log out", right?
(Reporter)

Comment 3

18 years ago
Is it really that hard to just put the dumb link there? It's not like you'r 
going to the moon. No perl needed terry.
Severity: major → normal

Updated

18 years ago
Summary: No way to log in to bugzilla from bugzilla.mozila.com, Can't view saved querys immediatly. → No way to log in to bugzilla from bugzilla.mozilla.org, Can't view saved querys immediatly.

Comment 4

18 years ago
First of all, it wasn't at all clear from the original bug report that this is
what you were asking for.

Second, it is a bit annoying, in that the "log in" link wouldn't actually prompt
you for a name and password if you already have a valid login cookie set.  It
will just take you to the query page.  That seems pretty buggy to me.

Of course, it would be possible to make a "log in" link that would only display
if you weren't logged in, or make it always prompt for your name and password
even if logged in, or something like that.  But for that, I *do* need perl code
(or even worse, javascript).
What about instead of using just a "log in" link, having:

 * Query Page (Search existing bug reports) 
 * Query Page (and login if needed) 

...on the front page?

Comment 6

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
My suggestion is to just have a log in page.

If you're already logged in, it should trash your old login and relogin (and say
so on the log in page).

It should just take you to a page that says you're now logged in, including
links to the front and query pages.
QA Contact: matty
This might depend on if they have their footer on.  If they do, there probably
is no need to tell them they are logged in on a message page.

Also we should take them back to the page they came from.
Easiest way to fix this would be with a CGI page for the index page so you can 
customize what they see based on if they're logged in or not.  There's another 
bug for that around here somewhere...
Severity: normal → enhancement
Summary: No way to log in to bugzilla from bugzilla.mozilla.org, Can't view saved querys immediatly. → No way to log into bugzilla from index.html

*** This bug has been marked as a duplicate of 15967 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified

Comment 13

16 years ago
Verified dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.