Download stalls for two files downloading with the same name

RESOLVED DUPLICATE of bug 236514

Status

()

RESOLVED DUPLICATE of bug 236514
14 years ago
10 years ago

People

(Reporter: jagginess, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

I'm using firefox running with fedora core 3 (i386 platform). 
Here's an excerpt from rpm.
Name        : firefox                      Relocations: (not relocatable)
Version     : 0.10.1                            Vendor: Red Hat, Inc.
Release     : 1.0PR1.20                     Build Date: Wed 20 Oct 2004 03:45:40
AM EDT
Install Date: Tue 01 Mar 2005 06:21:30 AM EST      Build Host:
tweety.build.redhat.com
Group       : Applications/Internet         Source RPM:
firefox-0.10.1-1.0PR1.20.src.rpm
Size        : 21611838                         License: MPL/LGPL
Signature   : DSA/SHA1, Wed 20 Oct 2004 02:50:06 PM EDT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mozilla.org/projects/firefox/
Summary     : Mozilla Firefox Web browser.
Description :
Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance and portability.

I chose to download a file from sourceforge (mirror x)
eg
http://prdownloads.sourceforge.net/wxpython/wxPythonGTK-py2.2-2.4.2.4-1.i386.rpm?use_mirror=optusnet

and then later decided to download an edition-copy of this file from another
mirror.(mirror y)

The issue was that downloading was triggered from mirror-y and, what seems to
appear, mirror-x downloading progress status in the downloading manager seemed
to have disappeared. When downloading from mirror-y was seemingly complete, it
just stalled- that is the progress bar was left hanging at 100% and the
label_item "Cancel" remained rather than "Done". The file wasn't saved on the
drive either..



Reproducible: Sometimes

Steps to Reproduce:
1. Download a file from the internet.
2. While this file is downloading, download another edition-copy of this file
from another url. (same filename)
3. May Preferences settings have an effect? I have set for "Downloads" - Save
All to Desktop folder, and not the prompt of ask..
(Perhaps an additional setting switch for 'Treat-downloads' automagically with
auto file-renaming (eg:filename.gz, filename.gz_0) or an Prompt me for same
filename to rename?)


Actual Results:  
See details

Expected Results:  
Prompt for another filename if another file is downloading the same directory
location despite Preference settings of saving all to Desktop; or have the
program popup a box mentioning an automagic renaming for preventing file
overwriting in this case.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 236514 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.