Enabling JavaScript could block PC from internet access

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
2 years ago

People

(Reporter: mozilla, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

1. The setup that causes the problem: JavaScript enabled. Firefox 1.01, and has
Adblock extension V.0.5. The option Java (Sun JVM)has no effect.
2. Same setup has no problem with Firefox 1.0. Problem pops up since ver.1.01.
3. Repeatablity: every time. I use www.latimes.com It has lots of JavaScript ad's.
4. Test: Enable Java and JavaScript. Enable extension Adblock V.0.5. (Adblock
should have block list of most of latimes.com ad's). Read www.latimes.com
normally. After a few (less than 10) moving from one headline to another, from
page to page, eventually, you'll lose internet connection (will show status
'www.latimes.com cannot be found'. If you then try going to Google.com, it could
not be found either). If you open a DOSPrompt window and ping www.yahoo.com, it
tells you're disconnected. 
I use cable modem. Initially I thoght my hardware or my cable company has
intermitten service problem. I had to chase all these down and found the
problem, and the temporary solution.
Note that some sites do not have this problem. Only sites use lots of JavaScript
have this problem. For example, Officmax.com has no problem, Staples.com has
problem. (Or could be I did not surf long enough in those 'no problem' sites).
5. Cures: a) Sun JVM has no effect, but unselect JavaScript cures the problem.
          b) Enable JavaScript, but disable Adblock. Problem also gone.
          c) Close Firefox, wait a few seconds, open DOSPrompt and ping a site
(I pinged www.yahoo.com) to re-establish internet connection. Or wait longer
after closing Firefox, say, 1 minute or longer. Or reboot PC.

Sun JVM has no effect, but I did uninstalled old and re-installed new jre
1.5.0.02 in trying to solve problem. As I said, only selecting the option
JavaScript, and together with Adblock, to have this probelm.


Reproducible: Always

Steps to Reproduce:
1.Enable Java and JavaScript in Firefox1.0.1, enable Adblock extension 0.5, with
list of blocked ad's in it. No internet proxy is used, a direct connection via
cable modem and router. ZoneAlarm has no effect.
2.Surf www.latimes.com. Read title/headlines, pages to pages. Eventually status
text will show 'www.latimes.com cannot be found.'
3.Keep Firefox on. Open DOSPrompt window and ping www.yahoo.com.

Actual Results:  
Result: Ping www.yahoo.com will fail: lose internet connection. Other programs,
such as Skype, will also lose their connections.
Solution:
Close Firefox 1.01. wait a few seconds to one or several minutes. Ping a site.
Connection re-established. Or just close Firefox, wait, re-launge.

Expected Results:  
How can JavaScript usurp the entire connection and won't let go? Rectify the
JavaScript interaction probelm.

Hardware: Dell Workstation 850MHz P3 512M Rambus, scsi hdd/Adaptec ultra-wide.
Internet connection: Cable modem, Linksys router, direct/no proxy
Software: Win2000/sp3. Firefox 1.0.1. ZoneAlarm, Sun JVM V.1.5.0.02. Firefox
Extension Adblock V.0.5 D2 Nightly Build 39, with ad block list in it.

Comment 1

14 years ago
Hi Steve,

First off, just to clear up a misconception so that you don't pull any more
hairs out over there. Javascript has nothing to do with Java. It's unfortunate
that it was named Javascript, but that's something we can't change now. So
changing your JVM will have zero effect on this issue.

Second, it sounds like you're only having this issue with AdBlock enabled. If
that's the case, then you'll have to file a bug with the author of AdBlock,
since issues with specific extensions are not supported by Mozilla.

I'm therefore marking this bug as invalid. If you see this problem without
AdBlock, then feel free to reopen and someone will test it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.