Navigator is unable to switch to Mail & News when Account Settings are opened -> uncaught exception [error in JS console: tasksOverlay.js :: toOpenWindow]

RESOLVED DUPLICATE of bug 165668

Status

--
minor
RESOLVED DUPLICATE of bug 165668
14 years ago
13 years ago

People

(Reporter: aha, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
2005032005/SM-trunk/WXP

Repro:
1. open Navigator window
2. open Mail & News window
3. open Edit | Mail & Newsgroups Account Settings
4. go to Navigator window
5. hit Ctrl+2

Actual:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://communicator/content/tasksOverlay.js :: toOpenWindow :: line 89"  data: no]

Comment 1

14 years ago
I don't see the exception, but I can reproduce the problem

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
With Mozilla 1.7.5 and 1.8b1 I can't switch back to Mailnews with Ctrl+2 and I
see the exception in the JavaScript console. Switching to the already opened
Mailnews window in the Window menu also doesn't work, but switching to the Mail
& News Account Settings window does work.

Comment 3

14 years ago
Confirming with Mozilla 1.7.6 on WinXP. I see the same error in the console like
in comment 0.

Comment 4

13 years ago
I found it, known bug.

*** This bug has been marked as a duplicate of 165668 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Navigator is unable to switch to Mail & News when Account Settings are opened -> uncaught exception → Navigator is unable to switch to Mail & News when Account Settings are opened -> uncaught exception [error in JS console: tasksOverlay.js :: toOpenWindow]
You need to log in before you can comment on or make changes to this bug.