Products that should be invisible show up on query page

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Matthew Newman, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

When in the search page on Bugzilla, the product listing lists all the specific 
groups for the users. The user must highlight one to search that specific 
group. If no product is highlighted however, it returns the results for ALL the 
products and alls for the user to edit all of them.

Reproducible: Always

Steps to Reproduce:
1. Go to the search page. 
2. Do not highlight any products.
3. Click search.

Actual Results:  
It gives you a listing of all the bugs, regardless of the product. 

Expected Results:  
Not known.
(Reporter)

Comment 1

13 years ago
This can be solved by replacing the 'list' of products, with a drop down list. 
Can anyone post the fix?

Thanks

Comment 2

13 years ago
The actual behavior is what we want. Selecting no product is equivalent to
selecting all of them. You are free to select none, one, several or all of them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
To clarify what Fred said, each item on the search page further restricts your
search.  If you don't pick something within that widget, then it's as if that
widget wasn't used, and it's not used to restrict your search.
(Reporter)

Comment 4

13 years ago
Ok. But, notice on this page, the products, ie Bugzilla, Core, etc, are 
formatted in a drop down menu. Can someone help me retro fit my Bugzilla, in 
this fashion? Or just some example code and where to put the snip.
(Reporter)

Comment 5

13 years ago
Allow me to be more specific, 

When you do not choose an option for "Product", you get all the options, as 
Fred noted. However, the users can then have full reign over all the products, 
even if they do not have access to that specific product. 

Thanks for any help,

Matthew Newman
NBC Universal
Broadcast & Network Operations
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
If the users don't have access to enter bugs into that product, then it won't
show up at all on the search page.  If it's showing up on the search page, they
have access to it.  Your access restrictions on your Bugzilla are probably not
set up the way you think they are.
Let's clarify further here...  which tab do you have selected on the query page
when you see this?
(Reporter)

Comment 8

13 years ago
Tabs? Not sure exactly what you mean. I click the search tab, then just 
click 'search' with all defaults. I appreciate the look at the problem Dave.
OK, what version of Bugzilla are you using?
OK, the reporter emailed me to say he's using version 2.16.6.

So you have no tabs on your query page (that's new in 2.18).

Next question, are you refering to the select list on the actual query page or
to the product popup menu in the "change-multiple-bugs" form?
(Reporter)

Comment 11

13 years ago
The select list on the actual query page.

Comment 12

13 years ago
Then this is not a bug in Bugzilla, but something that you want to change
locally. However, instead, I'd recommend that you use 2.18 and have your users
use the Simple Search page.

The query page is behaving as is intended.

This is not a support forum, but is a method for reporting product bugs. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Comment 13

13 years ago
Oh, wait, I see the problem being reported here. So the actual problem you're
reporting is that products that should be invisible to users actually show up in
the query page?

I don't know how groups work in 2.16, so I don't know how else to talk about
this problem.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

13 years ago
Summary: if no product is highlighted from list, returns all products → Products that should be invisible show up on query page
(Reporter)

Comment 14

13 years ago
Apparently the default setting bug security as it pertains to particular 
products is to leave the bug as "public". I was unaware of this, my apologies. 
Unfortunately I am interning here and picking the work up from a previous 
intern. 

Is there a way in the code of "bug_form.pl" to make it so that the DEFAULT 
setting is to set the bit in the database in order to make all bugs 
automatically private. I appreciate any help on this,

Matt Newman
NBC Universal

Comment 15

13 years ago
Matthew:

  What you are asking for is exactly what I did in bug 147275 which is a
standard part of Bugzilla 2.18 
  The migration process should be extremely smooth so I strongly suggest you
upgrade (always make a good backup first)

See http://www.bugzilla.org/docs/2.18/html/groups.html for information on the
group controls.  They were designed with your exact sitation in mind.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.